RE headers when compiling to mobi

I’ve been wrangling an acceptable mobi version of my book, but the Kindle reader stations a capital letter header atop every page. I’ve read up on formatting to remove this on the title page at least…but the option doesn’t appear to be available when outputting to Kindlegen.
Any suggestions?
Is it possible to eliminate the automatic page headers for Kindle, or modify them?

Thanks

Do you mean the stuff that the Kindle device displays around the book—like location/percentage read, and maybe the book title on some devices? If so, no that’s not a feature of the book itself, that’s as much “the Kindle” as the menu you get when you tap on the right spot of the screen. It’s not even displayed on every device—to my knowledge, none of the e-ink and iOS readers display a header, and will only toggle display location information when you tap along the bottom of the screen (same as in the iOS app). It may only be their Fire tablets that display it.

I’m speaking of the book’s title being present in capital letters at the top of each page. Like so:

                                                                        BOOKNAME

I’d figured it was Kindle generated, but having read a compilation guide that mentioned removing it on the title page, I’d wondered if there was any means of eliminating it, or changing it to lower case, italics, putting it to the side, or whatever. I’m looking into Calibre for such tweaking, but thought I’d ask. Seems clunky and obtrusive.

For printing and exporting to word processors that handle headers/footers, yes. But like I say, this isn’t a feature of your e-book, there is no way to control it short of writing a complaint to Amazon and hoping they change their e-reader software.

Thanks, AmberV

Also, it was creating TOC items for each document. So I unchecked the page break boxes and this fixed it except for one entry. It’s still listing in TOC. By the way, I’m using ‘as is’ setting on all, but tried it either way with same results.

Check the Separators compile pane, page breaks can be generated there as well (and are, by default, for folders followed by files).

It is also possible to have page breaks directly in the text, turn on Format/Options/Show Invisibles and check this section in question for breaks. You can see an example by inserting one yourself, with Edit/Insert/Page Break.

Nothing in the separator pane.
I’ve tried adding and deleting page breaks on and around the page in question, and it doesn’t help.
It’s a title page built of a couple of image files. Could that cause it?

Okay to step back a bit and check something: when you said there is still one ToC entry left that you can’t get rid of, did you mean that in the sense that you’re trying to get rid of the last one, or something else? Because if that is what you mean, that’s what it does if nothing is eligible for a section break, it just uses the first item’s name in the list—it has to have at least one. There is no way to not have a ToC, in other words. You would need to cut that HTML page out and fix the internal ToC as well, using a tool like Sigil or Calibre.

It’s the title page, contained in the Front Matter. Then the actual chapters follow. So…

unwanted item
1
2
3…

Oh okay, I think I understand, and I don’t see a way around that from within Scrivener. The stuff coming before chapter 1 needs a file to be put in, and so that is why it is listed (Scrivener is programmed to just make a ToC entry whenever there is a new section). My advice would be essentially the same: you’d need to remove that line from the contents.xhtml page in Sigil, and then use Tools/Table of Contents/Edit Table of Contents to remove the entry from there as well. That should work fine.

hmm… I’ll give it a try.

Thank you

OK. Got that taken care of. Thanks, AmberV.

Let me ask a couple others, if I may.
There are several blank pages appearing after the cover, as well as following the page break on certain chapters [but not all]. Results in paging to a blank screen. Not such a big deal, but I’m curious.
Also, while using Calibre to remove the unwanted TOC item, I tried to un-bold the CONTENTS header, but eliminating the surrounding s does nothing. Any ideas?