re-install Mac OS X - scrivener won't start

Because of some troubles unrelated to Scrivener,
I backed up my MBP disk to an external disk,
and then did a clean install of Mac OS X
which included restoring the files from the backup disk.

It fixed the unrelated problem I was having,
but when I tried to open Scrivener,
its menu appear briefly then Scrivener exited.
It crashes or quits without warning.

I tried reinstalling it.
No luck.

Based on a log report I found
(see code at end of this post)
I fixed the problem with the following commands:

   cd /System/Library/Frameworks/QuickTime.framework/Versions/A/
   sudo mv QuickTime Old_QuickTime_Old
   sudo cp /Volumes/myBackupVolume/System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime .

But I have no idea it this was a good idea or not.

Please advise what I should do.

Here’s the log I found in


Host Name:      My-Computer
Date/Time:      2007-05-19 21:01:42.149 -0700
OS Version:     10.4.9 (Build 8P2137)
Report Version: 4

Command: Scrivener
Path:    /Applications/
Parent:  WindowServer [59]

Version: ??? (1.03)

PID:    2076
Thread: Unknown

Link (dyld) error:

Symbol not found: _QTGetMoviePlayabilityState
  Referenced from: /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents
  Expected in: /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime

It looks like when you reinstalled, you didn’t install the QuickTime frameworks for some reason. Scrivener relies on the QuickTime frameworks, so if they aren’t present it can’t launch. You copied your backup of the QuickTime framework back in, so that is why it works again now - though it would probably have been better to reinstall QuickTime, as I’m not sure if there are other elements that you may need on your system (not so much for Scrivener).

All the best,

Since re-installing have you run software update? What version of OSX are you using? (About This Mac) What version of Quicktime are you using? (System Preferences > Quicktime > Register > About Quicktime … )

Yup. That was the first thing I did after reinstalling the OS.



Hmphf. I assumed that Quicktime would’ve gotten updated to the latest (7.1.6) when I ran System Update.
On a hunch, I ran System Update again, and, sure enough, a whole slew of new updates appear.
I now see that, after a clean system install, running System Update ONCE is NOT enough.

Thanks for your help.

Yeah, you might have to run it several times to get everything all cleared. There are several packages that rely on other packages, that is why they do not all show up at once. On a new install, I typically update everything (keep running Software Update until nothing shows up anymore, or everything left is unnecessary). Then install all of your software, and run it again just to make sure. Some programs trigger further updates once you install them, such as iWork.