Read-Only Projects Error

Guys,

I dragged an old copy of a scriv catalog to my desktop using Time Machine. Now it won’t let me open the file. Advice? I’ve checked all permissions and it keeps happening.

Scrivener does not support read-only projects. Check the permissions for this project in the Finder, and ensure that it is not stored on a read-only volume such as a disk image.

My first instinct would be to restore the Scrivener project using the proper menu item in Time Machine, rather than dragging, and see if that makes a difference.

M.

A .scriv project is really a folder full of files (a file package), but Finder for some reason doesn’t let you set the permission on all enclosing files for file packages, only for folder. So it may be that there are files within the .scriv package that are still read-only. To workaround this:

  1. In the Finder, Get Info on the .scriv file.

  2. In the Get Info panel, remove the “.scriv” extension and agree to the change. This will turn your .scriv file into a regular blue Finder folder.

  3. Close the Get Info panel and then Get Info on the folder (you must close and reopen Get Info - this will change the options available as it will reload and now look at the file as a folder).

  4. Click on the lock at the bottom and enter your administrator password.

  5. Ensure that you have “Read & Write” access.

  6. Now click on the gear button and select “Apply to enclosed items…” This is the key step that ensures all files within the package have the correct permissions.

  7. Once that is done, add the “.scriv” extension again.

All the best,
Keith