Recent projects don't show up with LaunchBar

I’m just loving Scrivener 2.0 so far – it is just an amazing program – but there are a few things that don’t seem to work the same as before and I’d like to know if there’s a way to do them. I’m breaking these up into separate posts for clarity…

I used to launch my Scrivener projects via LaunchBar. LaunchBar has a feature where you can quickly choose an application and then choose a recent project for that application (e.g. typing “sc na” would launch my Scrivener project called “Napkins”). Scrivener 1.54 did this just fine but with Scrivener 2.0, I don’t see any recent programs listed any more. I honestly don’t know how this functionality works, but I imagine there is some standard Mac way to record recently opened programs in a way that is accessible to other applications. Did this Scrivener functionality go away? I made sure to relaunch LaunchBar and reindex everything and open&close Scrivener projects a few times before posting this message… I admit a lot of this stuff is magic from my perspective so I could be doing something wrong unrelated to Scrivener.

Thanks for any pointers…


I had that same problem off and on with LaunchBar, back when I was re-installing test releases on a frequent basis. It will make sense for that to reset sometimes, if the recent items preference file gets wiped (which it will when you upgrade), but I could never figure out why it would sometimes just fail to acquire new entries after being used for a while. LaunchBar just uses the application’s standard recent items plist file, if you have items in File/Recent Items, but not in LB, then try logging in and out. If you have an empty menu item, you could try closing Scrivener, deleting com.literatureandlatte.scrivener2.LSSharedFileList.plist from your Library/Preferences folder, and then launching Scrivener, loading a project, and seeing if the menu gets populated.

Thank you for the feedback. And for some insight regarding how the recent file list thing works. After trying a few of your suggestions without success, I noticed that the plist was named “scrivener2” while the app is just named “Scrivener”. So I renamed the application to “” and it worked. Now I don’t know if this works because the name is now in sync with the plist filename or if it was just the act of creating a new application that solved it, but in either case it works now. Though now I wonder if there will be any negative side effects to renaming the application… ??? Thanks again.

That might cause the services to break; the NaNo version had this problem because it wasn’t called “Scrivener” so the clipping services couldn’t find “Scrivener” correctly. Interesting results though, it looks like Launchbar determines that list based off of simple filename, which would make sense. Now I’m wondering how mine is working without that name change. :slight_smile:

Hmmm… I’m having this same problem. I tried to fix it by duplicating the scrivener pref file com.literatureandlatte.scrivener2.plist and renamed it to com.literatureandlatte.scrivener.plist

So now I have two of them in there…and I’m not sure if this is going to cause me problems down the line or not. We’ll see.

Amber, maybe you still have a pref file for scrivener 1 in your username/library/prefs folder?

I do, but then you’d think LB would be showing the recent list for the test projects I’ve opened in Scriv 1, not the ones I’ve loaded in Scriv2, which are in the second pref file. It isn’t really something I ever tried to troubleshoot or resolve, because when it happened to me it was—like I said—in the middle of a bunch of test releases that were flying around, and so stuff like that was a very low priority. When it started magically working later on, I just forgot about it. The only change I’ve made since then is several reboots.