Recent Projects

Not sure whether I should report these issues or not, I’ll risk a flame because I think it’s important.

  1. Reopen recent documents does not seem to work. I have to open my last document each time. (PREFERENCES>GENERAL>STARTUP OPTIONS)

  2. I’m getting a very annoying lag as I type a string of words. It takes ages for Scrivener to keep up. Tried this on a couple of other apps and it is definitely only Scrivener at fault. If it helps, I think it is something to do with the automatic saving that is going on in the background. Can I allocate more RAM to Scrivener?

Am I missing some little trick or other?


Does the lag happen in new, empty projects, or just big ones? Also, have you tried logging in to your account with the shift key held down? This will disable any background processes that are set to automatically load in the background when you log in. It is not a solution, but it might help isolate the problem if it is some other application conflicting with Scrivener. I’m pretty sure auto-save is not the problem. If you watch the window close button in the top left, a dot appears whenever the project is not saved. While typing, the dot stays up there continuously, and then disappears a few seconds after you stop typing. When the dot disappears, you might hear a hard drive tick. That is auto-save happening.

…and allocating RAM to applications is so 1999. :wink:

I know the lag. I experience the same with Final Draft from time to time. One solution is to restart the app. Better is to go through some standard routines of system maintenance from time to time.

For exemple Onyx is a free app:


Yes. AmberV, you spotted it straight off. It is only with big projects - 120 minute film+notes+research+previous version 120 minute film, etc - all the things I adopted Scrivener to handle.

Yes, Dynamic RAM, great idea - in theory. Guess I have to buy more RAM if I want to use Scrivener. Dang, thought I had enough with 1 GB.

I was wondering if it possible to exercise a choice to ditch some of the overhead - for example I have no need for Multimarkdown or any of the other stuff that is not directly related to writing books and films, such as footnotes etc. Don’t misunderstand me - they are brilliant, even necessary for others - just not for me when the cost is a real brain shift when what I type does not appear on the monitor. It really interferes with the creative flow.

So any practical advice would be very welcome.

EDIT: I used AmberV’s ideas as clue and pretty much stripped the log-in items in system preferences and I think it helped.

Yes Mel,

I ditched FD for the same reason and now use Screenwriter Pro 6 (soon to be released).

I posted the Onyx reference earlier today: … .php?t=781

How is that for serendipity?

Believe me, I got royally flamed a few weeks ago for suggesting system maintenance - I do it anyway - every month. My system is as clean and lean as can be. This is definitely a problem related to the size of the stuff Scrivener is handling at the time - also perhaps related to the g4 I am using, it is only a 733 Hz chip.

Thanks for the kind thought, much appreciated.

Even if you could do that: These features are much more minimal than you realise. I would guess that footnotes are only slightly more heavy-weight than bold and italics – and of no impact whatever if you do not use them (they are written in the RTF file like any other format decision – same goes for annotations). MMD, most of that is not even Scrivener, it is a bunch of Perl scripts and XML files that, if never invoked, will do nothing but take up 600kb on your hard drive.

You could try playing with how much interface you have visible in Scrivener. Try turning off Inspector, leaving the Keyword HUD hidden, and leaving splits alone until you need them (I’d suspect splits are eating the most processor in Scrivener, unless you’ve got too different files open – then it might not make much of a difference). Oh, one thing I forgot to ask: Does working in Full Screen mode make a difference? Does the problem show up there too?

Hmm. That is all I can think of for now. I’d be curious if anyone else is running an old processor like you, and if they have similar problems. What you are describing sounds to me more a CPU issue than a RAM issue; but really I am just guessing. 1gb should be more than enough.

Edit: I might be wrong about this, but I think Scrivener just pre-loads text. Having a ton of multimedia research should not require a lot of RAM. Most of these are displayed using common Apple libraries – and I would imagine they are only accessed on demand. Text is another issue entirely. All text is pre-loaded to make the outline feel more responsive.

Hi AmberV,

Thanks for info re configuration of Scrivener (overheads etc). Yes I think a lot of the problem is the 733 Hz CPU.

Not much point in using Scrivener if I can’t keep my reference splits open while I work - might as well just get up a couple of Nisus or Mellel or MarinerWrite windows. To me the vertical splits ARE Scrivener.

Looks like i will have to sell my children to medical science and buy a new computer.

EDIT: Looks like I can keep the kids after all. I think the culprit was Ascertant’s Versomatic. It plants files all over the place - nasty piece of work. It just keeps going like the clappers all the time. I think that was the what was consuming CPU time.

I ditched it. Now the drive is quiet. Scrivener seems to be OK now.

Wow! what a nasty experience. Thanks for the clues AmberV. It was just enough to point me in the right direction - the bit about CPU.


Glad you seem to have solved the issue for now, Lord Lightning. I have to admit that I have never tested Scrivener on anything less than a 1GhZ iBook (768MB RAM), so it most likely was that the CPU was being eaten by other processes.

There is of course no way to ditch elements of the program such as footnotes and MMD - and absolutely no need, either. Elements you don’t use take up no memory/CPU power at all.

Amber is right that Scrivener does keep text in memory, though. If you load a long chunk of text, it is kept around in memory until you close the project. This is so that you only have a lag when opening each document for the first time - after that, it should open instantly. It would be possible to make this a preference, so that no memory is used by inactive documents. I will try to remember to add this to the list - if I don’t, remind me after Christmas. :slight_smile:


Excellent! Thanks Keith. It will help a lot. Mind you, the kids will be fatter and more marketable after Christmas.

Just an afterthought. re the recent documents item.

Any thoughts there?

Happy Christmas to you and yours.

Lord Lightning,
iStat Pro is a handy little (freeware) widget for watching what your CPU is up to.

I use it for keeping an eye on battery conditions, but it also looks at memory, network, temperatures, and disks, and uptime, as well as the CPU. … atpro.html

Regards, Leigh

Excellent Leigh,

Much appreciated. Nice little christmas present.

Happy Christmas to you.


Interesting thread, because I am noticing exactly the same thing. LL, I dont have that program you mentioned–Versomatic–but I’m wondering if something else I have running might be causing the lag? Perhaps other programs I have running. I’ll experiment. I don’t see anything on Activity Monitor, but with long documents it gets bad. I’m running it on a 1.2ghz iBook with lots of RAM (1.25 gigs), so no issues there.

Any thoughts on where I might look to solve this problem? I can copy and paste the text to Text Edit or another processor and the problem goes away in those programs. It only starts happening when a file gets long, 5+ pages or so (when printed). But many of my chapters or articles will be longer than 5 pages.



Recently I also started to experience the lag. My project has grown to 61,793 characters / 9,995 words. (The latter are German words which have the odd habit to be longer that their English counterparts.)

I was not yet able to fully isolate the problem. But I can definately rule out CPU power (or lack thereof) because I’m running a MacBook Pro 2 GHz with 2 gigs of RAM which even has been enough for Java server development :wink:

I mainly seem to experience it in full screen mode, especially with documents larger than 500 words.

Any ideas?


with 300.000 words (German :wink: ) my main project is rather large as well, but I do not experience that lag. Neither in smaller projects. My main machine for Scrivener is an iBook G4 with 768 somewhat RAM.


I am still leaning towards a conflict between applications when it comes to lag. I have tested Scrivener with some truly abusive project sizes and loads of multimedia, and I’ve never experienced any typing lag. The application does indeed slow down when loading many hundreds of thousands of words into Edit Scrivenings or full screen, and when exporting – but such is to be expected. That is a lot of work for any app to do.

There should be absolute no problem with a 500 word document. The types of potential conflict applications to look for would be the sorts that track what you are typing, such as third party spell checkers, typing abbreviation expanders, text doublers (such as Versomatic and Backtrack). Potentially, applications which are monitoring window and mouse usage, too, such as CocoaGestures, Zooom, FlySketch, DragThing and so on. I personally use Typinator and Zooom (and I was using CocoaGestures before, but had to disable that because it causes Path Finder to crash from time to time). Neither of these seem to conflict on my system.

It might be that Scrivener’s rich text engine, which has been modified to provide support for advanced features, might be having more troubles than applications that use the vanilla rich text widget, such as TextEdit. That is a wild guess.


I don’t use any of the programs you mentioned. However, I use Quicksilver which every 10 minutes or so scans parts of my system. But my machine should be able to handle it, shouldn’t it? Anyway, I will look into it.

Mind you, the lag is not very serious, it’s more like an ocasional stutter, so I can live with it. I’m not even convinced that it has anything to do with my document or project sizes.

Keith, can you rule out the possibility that it has something to do with auto-saving? Recently when I experienced the lag I was running my machine in battery mode, and in this mode to save energy I allow the OS to spin down my hard drives. So perhaps the auto-saving causes the hard drives to wake up, thus causing the lag?

Speaking of auto-save, I sometimes whished I could turn it off. Because the other day I modified my prose in such a horrible way that I wanted to return to the state that I started from. Unfortuantely I didn’t make a snapshot and my destructive modification had been auto-saved, so I was pretty much at a point of no return.

Quick reply: Auto-save only happens after Scrivener has been inactive for 2 seconds and only if there is something to save. Every time you make a change (type, click, whatever), Scrivener is told to register an auto-save-if-necessary after two seconds of inactivity. So, if there are no changes, the auto-save does nothing; if you are in the middle of typing, auto-save waits for you to finish; if everything is saved and Scrivener is idle or you are working in another app, Scrivener does not even try to auto-save.

I have said lots of times that Auto-Save will not be optional for the foreseeable future - it is hardwired in. Why couldn’t you just undo your work? Each main text has its own undo stack, so you can undo changes to any text throughout the entire session, even when you change documents several times. The undo stack only gets lost when you quit Scrivener. So you could have just taken a snapshot of the text you didn’t like and then hit undo until you got back to the original text…

I have not experiences this lag myself yet, so please keep me up-to-date and I will try to reproduce it. It should not have anything to do with the auto-save, though…


I cannot fully recall how I messed up my document but I seem to remember that I couldn’t reconstruct the state by undoing… Don’t ask me why, it was late at night… so don’t worry, it was basically my own fault.

About the lagging: Today I experienced it again, and I had Azureus running, downloading some torrents. When I quit Azureus the lag was gone. Before quitting I examined the running processes with the ProcessViewer. Azureus (being a Java app) ate quite a lot or memory (100+ meg) but by no means all of it. But it might have had an impact on Scrivener.

I have not been able to isolate the lag issue regarding any other program that might be running. There seems to be nothing else running at the time and nothing showing on activity monitor. It happens increasingly as my file gets larger and it is a typing lag. I type something on the keyboard and there is a lag in it showing up in Scr. I also have noticed the ‘lag’ with auto-save and that is something different. I am used to that now and there is a little lag right when it’s autosaving and then the lag disappears. This is different. I’ll keep trying to isolate the issue. What I’ve been doing is copy and pasting to iText or Text Edit, but that is only because I’ve been in a rush at those times. And of course this is not desirable, since it goes against the whole reason I use Scr. in the first place. I’ll definitely try to do more to track it down.


Forgot to mention it is not happening in full screen mode, which I do not really use at present.