Recover _Recovered Files?

Early in December I downloaded the Scrivener demo. I went through the tutorial and started a handbook project I’ve been meaning to put together for some time. The rest of December intervened and it’s only now I’m able to get back to it. Apparently I did quite a bit of work. I can tell because there are a little over 200 files all gathered together in a folder called _Recovered Files.

When I double-clicked the file this evening, it launched in Scrivener Gold, which I had not realized I still had on my desktop. I didn’t recognized it at first because I’m so unfamiliar with Scrivener, but none of my work was visible (not even a _Recovered Files folder). When I realized what had happened, I quit and used Get Info to change the program that would open .scriv files. Now I find all my work sitting in a folder just below the Trash bin.

Is there a way to recreate the organization I had several weeks ago or would I be better off just starting over? Would the file opening in Scrivener Gold have corrupted it to this extent or is something else at work here?


I am not sure how Recovered Files work, but I do know that Scrivener Gold will corrupt files from the newer version mercilessly, so I expect you will not be able to get back much more than you currently have.

I think you are probably going to have to re-create the structure and drag the files into it.

Try doing a search on recovered files though, because I do remember Keith mentioning it recently.

Otherwise, I’m sure Keith or someone in the know will come along soon.

Thanks, Matt. I’ve archived the Gold version to get it out of the way. At this point I’m pretty sure I’ll be buying the full version.

As it turns out, the folder containing the file in question is one I backup regularly. So I copied that backup to my regular folder and renamed the first to corrupt. corrupt is about 1.5 MB while the backup is only 1 MB and yet there seems to be little difference in the package contents between the two. In addition, while Scrivener 1.11 (in demo mode) will recognize the backup file in its Open dialog, it won’t actually open it. No warning or message to indicate why at all.

Is a puzzlement.

When you say it won’t open it…

Are you sure it is not opening it? Or could it be opening it, but showing it as empty?

There have been a few reports of the latter (often related to corrupted packages due to versions etc.), so you might like to take a look at those threads (and also, that information might help Keith with his advice to you, when he next checks the forum).


I know it wouldn’t have helped here, because the OP didn’t realize he had an old copy of Scriv (g)Old still lying around, but I wonder if it’s worth even having Gold available on the site anymore. It doesn’t represent Scriv well, it might keep someone from buying the “real” version (which isn’t that expensive anyway and comes with a free tryout period) and, as this incident shows, can actually do harm. If nothing else, maybe the website description should have a warning attached to it – “be sure to delete Gold if you use Scrivener.”
And Keith could use the occasion to fix the typo in the Summarizer description. And add the recent plaudits from the NY Times and the Eddy award to the Scrivener home page.

Huh? What typo? I can’t see one…


The _Recovered files thing meant that something had gone a little wrong with your project earlier (nothing serious; just for some reason, files you had emptied from the trash had failed to get wiped from the hard drive. I’m still not sure why this happens - it is rare - but I added the _Recovered Files folder for this to prevent other strange behaviour that could arise in this case).

Unfortunately Scrivener Gold does royally mess up regular Scrivener files, and it may well be that it is time to retire that free version… Sorry!

Regarding the fact that the backup won’t open - could you try opening up (Applications/Utilities) - my guess is that something will be spewed out there if there is an error opening - probably something to do with a corrupt or nil dictionary, indicating a corrupt file.

All the best,

Once a copyeditor, always a copyeditor:


Summarizer is a simple freeware Cocoa application that allows you to breakdown the structure of any book or text that is * availalbe *

What’s really scary is that I wasn’t even consciously reading that description, just the Gold one above. Yet my copyeditor’s eye unconsciously spotted the discrepancy. I’d love to see some neurological study on this phenomenon to find out whether a different part of the brain is involved in things like recognizing spelling mistakes (or word puzzles – I solve jumbles the same way, almost unconsciously) vs. reading for meaning. It’s some kind of weird pattern recognition thing, by no means infallible but undeniably handy on occasion.

Nope, nope, can’t see it, it’s all fine, nothing to see here, move along.

(i.e. I’ve fixed it.)

Weird… I’ve read and re-read that page, and I even re-read it looking for a spelling mistake when you said about it, and I still couldn’t see it. Bloody double ascenders. Or maybe my grey matter is just getting hoary.


Don’t sweat it. It has nothing to do with writing ability. My mentor, a two time Pulitzer winner and journalism professor, cheerfully confesses to being the worst speller ever. Until the advent of spell checkers (which we all know aren’t infallible in cases such as homonyms) he claimed that, before turning in final copy, he literally checked each word that wasn’t obviously familiar against a dictionary. Maybe he still does.

While we’re on the subject: “breakdown” is a noun. The verb is “break down”, two words… :wink:

Here’s the text from Console after I double click my backup file.

===== Tuesday, January 8, 2008 8:12:46 PM America/New_York ===== 2008-01-08 20:15:03.589 Scrivener[499] *** -[NSKeyedUnarchiver initForReadingWithData:]: incomprehensible archive (0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0)
Does this mean anything or is it code for: You’re screwed.

No, it’s definitely not open at all.
With Scrivener active, there are no open windows. But, as I mentioned, looking inside the backup file’s package, all the docs are there.

Excellent idea.
I’ve had Gold on my hard disk for some time. When I saw this project coming up I went looking for software that might help and, after reading all the excellent reviews and comments regarding Scrivener, didn’t hesitate to download it and go through the tutorial. I was very surprised to see that Gold had been the program to launch when I double-clicked the file I had created in Scrivener 1.11.

Sounds like I’m out of luck in this case, though. Since it’s been a few weeks since I used the program, I’ll probably have to go through the tutorial again as a refresher course and then just start over.


Sorry - that is definitely code for “you’re screwed”. It means that the base binder file is corrupt - exactly what is caused by SG. I’m definitely going to remove SG as soon as I add the Eddy award info etc.