redefine style from selection

I made a block quote paragraph, changed it to bold italic, opened the styles panel, selected ‘redefine style from selection’, and while the example in the styles panel changed, the selected text only switched back to ‘no style’, so I reselected it, and selected the ‘block quote’ style again ( which was correctly showing my changes ), but if failed to change to what it should be, even though it is now marked as a block quote paragraph in the toolbar.

Expected behaviour:

  • dont switch back to no style
  • apply my changes to any paragraph marked as that style throughout the entire document

Since there is no Styles panel in Scrivener 1.9, I assume you’re using the beta. Moved to beta forum. – Katherine

Thanks, and sorry I didn’t realise I hadn’t put it in the beta section ( yes I am using the latest beta ).

– another thing I would like to see with this, is that if I enter new list items within that defined list style, I could have a second type of exit, such that by creating a new line, but then backspacing to get rid of the bullet or numbering, instead of reverting to ‘no style’ it would assume I want my ‘body’ style to follow the list.

’no style’ is Scrivener’s equivalent of Word’s ’body style’.

Well that’s fine, but I still think we need to be able to define new styles and behaviour in the manner I suggested, though sure it may not be a high priority for the develops at this point.

But defining a new ’body style’ require that there is such a thing as a ’body style’, which there isn’t. So what you are suggesting means that backspacing would have to open the dialogue for creating a new style, which would be extremely irritating for all those cases when one just wanted to end the bullet list.

I just searched the manual and menus, and found an option under formatting: “Make Formatting Default” – can anyone confirm whether or not I am understanding this correctly … by selecting this option, I will be able to replace ‘no style’ with my preferred ‘body’ style, as the default which is used, and thus I would have to manually select ‘no style’ for any other case where I actually want to revert to that style?

While I appreciate that ‘no style’ is the current default, I would prefer to keep this as a kind of neutral base from which to develop other styles, rather than modifying it and using it as the ‘body’ style I actually want as the base.

I’ve partially answered my own question, which is that it seems what happens is that I can no longer use the ‘no style’ at all, even if I select it manually, it still appears in the list, but I cannot use it.

I do not know if this is a bug or a design feature.

In Word all text has a style and even if you don’t apply any styles all text will be given ’normal’ style.

In Scrivener the default is that the text doesn’t have a style. The text has a font, size, spacing, etc, but that is set in Tools -> Options (or Preferences on a Mac). It has ’no style’. The concept of style isn’t used the same way in Word and Scrivener and it seems that this is what creates your problem.

In Scrivener styles are only used for text that needs to have a completely different font, size, etc when you Compile, like block quotes. If you make a bullet list where the only difference is that it is abullet list, you just make it a bullet list. You don’t need to create a style for that. ’no style’ isn’t a style. It means that the text doesn’t have a style at all and the basic design of Scrivener is that it shouldn’t have a style, because you decide the formatting in the Compile settings, not in the Editor while writing. Scrivener isn’t a wysiwyg editor.

From your description it seems that you think of ’no style’ as a style, and it isn’t.