Registration Fails Peculiarly (Solved)

I purchased Scapple for OSX and Windows this evening. Registration on OSX went as expected. However, I have hit an odd registration issue with Windows.

OS: Windows 10 x64
Product: Scapple
Version: 1.0.0
Order Number: ST711962289

  • I enter my registration information…
  • Success, all is well!
  • … or IS IT?!

So yeah pretty strange. I realize Scapple on Windows is likely not the #1 L&L best seller with a frenetic development pace orchestrated by a large team in some kind of command center festooned with monitors and people wearing headsets. That said, for a variety of reasons, I have to use both OSX and Windows and would really like Scapple working after having purchased it.

I can confirm Scapple has written many things into the registry such as various keys to set the scapple.package file association, added itself to the path, and added a smattering of keys to HKCU\SOFTWARE\LiteratureAndLatte\Scapple. It would seem it should have all the registry access it requires yet apparently something is Deeply Wrong™.

And lastly, I am aware the OSX and Windows versions are licensed separately. I have purchased both and am using the Windows serial as specified in the ‘Scapple for Windows (Regular Licence) (SKU92970001775) (Windows)’ section of the receipt.

Any help appreciated.

Just tried again and it worked this time. So total success. Maybe I was experiencing connectivity issues with eSellerate when I tried? Regardless, happy to be registered.