Regretting installing Ubuntu 11.10

Well, is that true? Probably not - I like the look of it, and as a Johnny-Come-Lately to Ubuntu, I have no axe to grind about Unity. The problem is, is that I specifically thought to myself, “Look, chap {I actually did call myself that}, is changing OS just before NaNoWriMo tantamount to hang-gliding over the gates of Hell? I mean, it’s good to have an exciting life, but it doesn’t need to be that exciting…”

Low and behold, Scrivener no longer works in 11.10 (for me), and I can’t reinstall 11.04 (I don’t think) without doing a format, which I’d rather not do.

It is, actually, ok, in that I’m on a triple boot Hackintosh running MacOS 10.5.8/Ubuntu 11.10/JoliOS, so I can carry on on MacOS for the time being - but it will probably not come as any huge surprise to anyone frequenting the Linux forums that, if possible, I’d rather use Linux…

So - the problems are:

  1. Most of the buttons in the toolbars don’t work, which may be related partially to…

  2. … the cursor appears to click in the wrong place, and I can’t even get focus in anything other than the first column, and not in the right place even then…

I can type. That’s about it. Anyone else have this? Any ideas?

Thanks for your time in advance.

Had a similar cursor issue a while back, and can’t remember what the fix was except that it was something simple that someone here pointed out. I’ll look around, but in the meantime, wanted to give you hope that all is not lost. Well, okay, maybe all is lost, but we don’t know that for certain yet, do we? Not that I think the following should matter a whole lot, but are you running 32-bit or 64-bit? Did you upgrade, or do a clean install? And have you tried reinstalling Scrivener?

(Heh… and your setup sounds like mine from a couple of years ago. I was triple-booting Snow Leopard, XP, and Ubuntu on an Acer laptop just to run Scrivener, and one Windows legacy app–Later ended up doing a VirtualBox Hackintosh machine. Of course, now that we have Scrivener for Linux, and I found another solution for that legacy app, I’m a full-time Linux user. And notice how I’m keeping myself from ranting about how both Unity and Gnome Shell are abominations unto the computer gods, and that they make the ghost of Alan Turing cry? :wink: )

32 bit; I was somewhere in between a clean install and an upgrade, in that the upgrade crashed (well, my screensaver froze and I couldn’t get out of it), so reinstalled over the top of whatever was there (successfully) - that is, without a full format; and yes, I’ve reinstalled Scrivener, but not through your deb package (which I suppose is worth a lash, isn’t it?).

Good man. Top restraint! :slight_smile: Well, more restraint than Linus himself, at least…!

I also pride myself on my modesty.

Yikes…I’m hearing tons of complaints about 11.10. (More than the usual upgrade gripes.) For me, personally, I hated having to uninstall half the OS to make it usable for what I need. So it’s easier to use a distro that allows for more customization right off the bat. I have no clue what I’m going to do if/when the Slackware Benevolent Dictator for Life dies.

Is Unity really that awful? Or it it a case of people not being comfortable with it yet?

With Scrivener, are you absolutely sure you’re using the custom libraries that come with Scrivener? Is it installed in /usr/local/LiteratureandLatte? Is your path not pointing to /usr/local/LiteratureandLatte? Is there an old preference file that’s corrupted? (i.e. did you upgrade or was it a clean install of the OS?)


Hrm. That way always lies danger. I put my root partition on a separate one from my home partition, so i can do a clean install every time.

I’ve noticed that this behavior has re-appeared under 11.10 – however, the workaround for me is simply not to run Scrivener maximized.

I was prepared not to like Unity when I installed it with 11.04, but I’ve gotten to like it. Some nice shortcut features, and with my widescreen (16:9) display, the real estate is well-used. I come from a pretty minimal UI background (used to run fvwm under SunOS, pre-Solaris), so it’s not that I require eye-candy or anything. It’s also possible that some goofier design decisions will be made in the future, but usually there are ways around these things (dconf-editor, CompizConfig Settings, etc.).

Before upgrading, I set up a separate partition to play with 11.10 (so I could boot 11.04 if I preferred), and this showed that there weren’t any major surprises. In the past, I’ve migrated from one version to another rather slowly, and have either moved or just mounted my old home directory directory under the new install.

Hi guys - thanks for the heads up.

Just to clarify - I can do a reformat of my Ubuntu partition if necessary - and maybe it is. I have some time today - maybe I’ll try it. Was just trying to avoid it but essentially that’s more due to laziness on my part in terms of backing files than anything else…!

Will try the non-maximised approach too.

And finally - I have nothing against Unity whatsoever - I rather like it, but know no different, so can’t be held accountable for my opinions :slight_smile:

Right. Brilliant…

Now (as far as I can tell) Scrivener is working fine - I just can open any of the files I created in the MacOS version (which previously I could). The buttons all seem fine, everything’s getting focus as it should, I just can’t open anything (and they’re still working fine in the Mac partition.

Guess I’ll try and reinstall Scrivener…?

Yeah, I guess this is where I’m at - Scrivener seems to be working fine, but I can’t open anything I created on the Mac. It doesn’t give me any error messages or anything - it just doesn’t open, and I can’t find a way to export it from the Mac to the Linux side.

Any thoughts?


Sorry, can’t help with the Mac issue, I’m only running Ubuntu on my Thinkpad.
But since the update from 11.04 to 11.10 I can’t type in the main scrivener window any more, i.e. add to the text file. Using a non-maximised view does not help and is not a long-time solution anyway on a 12" screen. Adding to the synopses is working fine though. Guess I’ll reinstall this afternoon.

Unity took some getting used, but I love it now. Especially with my small screen…the docking station + big screen is several paychecks away yet. :confused:

Ok, my issue is not resolved yet, just refined. I deleted the tgz “install” I had of Scrivener and installed the .deb version from RobHamm on my 64 bit system. It seems the problem is not related to how I install Scrivener, as I simply did not see anything written in the window when the font was set to Courier New (worked before with 11.04), in the deb as well as the tgz based Scrivener.
However, when I compiled, I could see the things I’d typed in. So I changed the font to Ubuntu, and lo and behold, I can see the text I type now. But not the cursor. Which is beyond annoying.

Anyone out there with the same problem?

This sounds like an older issue that I used to see. I’m not seeing this currently.
The workaround – if it is the same problem – is to go to Tools → Options and either set to defaults, or go to Manage and load a preference file that you’ve previously saved.

A completely different work-around is to not run Ubuntu with Unity/Compiz – I know that under fluxbox, this issue doesn’t appear in Scrivener (11.04 or 11.10). This appears to be something between Scrivener and the way Unity handles the menu stuff (Unity-specific but not Ubuntu per se).

I sometimes take this route for a more distraction-less desktop environment when trying to write, since fluxbox is so much more minimal.

Thanks very much, I tried your first suggestion and it works again!
You just saved me having to go and look for another program for NaNo. I am ever so grateful, I was starting to really like Scrivener.

Awesome. (This used to be triggered by maximizing Scrivener and/or running in Scrivener’s own fullscreen mode, but I’m not positive which.)

I’ve installed Kubuntu 11.10, and I’m getting this message when I run it from the console:

Cannot mix incompatible Qt library (version 0x40704) with this library (version 0x40702) Aborted

I’m not sure where to go now, either… Is there a way to link the libraries needed to the system libs instead of the ones that come with the tarball? I think the difference in libraries is a minor version number, not sure. I never had this problem before with 11.04, or 10.10.

I have a feeling this is similar to the OP, I’m just running the KDE variant, so it relies on QT more and might have some differences.

I tried the .deb that is out there as well, and that didn’t work, either. It didn’t run at all.

Do you really think these are the same problem? I just want to be able to open a file, or find out how to Export it from Mac to Linux…?

Shot in the dark, re: the Mac files not opening, try checking the contents of the .scriv project directory and seeing if you’ve got multiple copies of things, either “conflicted version” type files (if you ever used something like Dropbox or other sync software) or just some extra copy of the .scrivx. The Mac version can handle opening a project with all these abnormalities, as it just ignores older copies, but the Windows version will choke on it so it’s not unlikely you’d see the same thing on Linux. But this is coming just from a Mac/Win perspective, as I make no claims to knowing anything Linux related except that it’s got the best mascot of any OS.

Or is it the “16” thing?

Just asking?