Regularizing font

When I paste multiple bits in differing fonts, I want to select all the text and change the whole thing to one font. If the cursor is in a bit with the correct font, that font shows in the top bar even after selecting all, and choosing it again does nothing. If the cursor is in a bit with a different font, I can select all and change it, which changes everything.

I would like to be able to select all, regardless of the position of the cursor (or regardless of the font of the selection in which the cursor is positioned), and set the font for everything selected.

Thanks for catching this! In the meantime, you could try using Paste and Match Style when bringing in your text, as this will strip all formatting and just match the current document settings, or using Documents>Convert>Formatting to Default Text Style on the document at the end of pasting to bring the whole document text into line with your current default formatting (which you can adjust first in the Editor tab of Tools>Options). The first method will strip all formatting and just paste as plain text, so you won’t want to use that one if you need to preserve things like italics and weblinks; the second method will keep those intact and give you a few additional options for what you want to change.