Remove all Formatting

I often find inconsistent formatting when moving between items in the binder. It would be incredibly useful to have a way to strip out all formatting. At the moment, I end up pasting text into Notepad and then copying it back into Scrivener.

Failing the above option, a way to reveal formatting visibly would be useful.

Or how about both?

The menu item Edit->Paste and Match Style (SHIFT-CTRL-V is the keyboard shortcut) will effectively do this as you add in text from other sources.

To clean up documents and make them match what’s set in Tools->Options->Editor, select the documents you want to strip all formatting from in the binder (CTRL-clicking will let you select multiple documents), then go to the menu Documents->Convert->Formatting to Default Text Style…

Note that this will strip out all special formatting, such as tab stops that differ from the default editor settings, special indentation as with an outline or block quote, and if you intended to have a swathe of text with a different font from the surrounding text, that formatting will be wiped out. When in doubt, take a snapshot before formatting to the default text style.

Hey guys! Your suggestions sort of did it, but not quite. I’ve had quite a bit of trouble with formatting in my book, especially when I cut and paste text or a particular section.

In this case, I copied a quote from a website and it carried with it the font, font color, size, and background color, but it still looked sort of funky after I cleared the text formatting. I’m guessing the ‘page formatting’ was still off somehow. Playing with the background color button clear it up.

In any case, having a button for this would be super helpful!

This occasionally still happens in my work, too. I frequently copy or import material from pdfs and websites, and even after converting to default style etc., sometimes some cruft remains. There are various text clearing utilities I used to use that you might try. Also on Mac Scrivener, I’ve had success with selecting the contaminated text and applying Format > Style > No Style. Maybe that’s the same function as converting to default style?