remove extra spaces on compile

Scriv2 Compile had a function (in Transformations?) that took out multiple spaces between words. In Scriv3, after considerable head-scratching, I found that one can ‘edit’ a compile format, which shows some of the former compile functions. There is no space removal option I can see. What am I missing?

There’s a command in the editor to do this now:

Edit > Text tidying > Replace Multiple Spaces with Single Spaces

That submenu also has commands to remove unwanted blank lines and so on.

HTH

FWIW, Convert Markdown and Convert MultiMarkdown remove multiple spaces during compile.

Thanks much, broker!

I hunted online and through the manual and I can’t figure out how the Text tidying works. Do I need to select the document before I pick text tidying? Does it do the whole project at once? Or just the selected part in the binder that shows in the editor?

Thanks!
Laurel

I might have missed a few contingencies in the menu command descriptions, but I did try to make note of where selection is pertinent. Most of them work on a selection/all basis, where if there is a selection it only operates within the selection, otherwise it operates on all of the text that is visible in the editor. None of them will operate on the entire project at once though—very few things do that, and if they do you will be warned since such operations cannot be undone.

You can usually tell by whether the command is active without a selection. The command to delete struck-through text for example requires a selection, and not only that it requires the selection to have struck-through text within it.

I actually can’t get Text Tidying to show up. All the options within it are greyed out. I’m not exactly sure what I’m doing wrong.

I couldn’t say without more information. It’s usually helpful to post a list of every single action you take, preferably starting from a point we can all start at too, like a blank project, describing each step you take to make it not blank enough for a test, and then demonstrating the problem with it.