Remove first line indent [sigh]

Hello, fellow Scriveners!

I’ve completed four novels in Scrivener. I like to believe I’m a fairly advanced user. In v2 I had no trouble with removing first line indentation, but in v3 it just not work. Everything else seemingly does, but this bothers me more than it should. What am I doing wrong … ?

I have three sections. Front matter as is. Chapters as folders with titles and blank space. And scenes. I’d like the scenes to remove the first lines indents … but it doesn’t. If I turn the uppercase words feature on. That works, but indentation remains.

I skipped my own setup and tried with the Manuscript (Times) preset which have the indentation removed in scenes. But also there it remains.

What am I missing?

Thanks :slight_smile:

I am not at a Mac now, but in the post linked below, a user explains how they switched on the option to KEEP first-line indents. Is it possible your compile settings have got this same switch inadvertently turned on?

viewtopic.php?p=266821#p266821

Also, what format (PDF, print, docx, ePub 2/3, etc) are you compiling to?

Does your manuscript use indents, not tabs?

Which file format are you exporting to? For most formats, this is controlled in the Compile Format editor in Section Layouts under “Settings”. For ebooks, this is controlled in “Text Layout” (which just inserts the necessary CSS - you can also edit the CSS directly). I’d need a little more information to give further help, though.

All the best,
Keith

Thanks :slight_smile:

I’m compiling to print. My text uses indentations.

Even though the ‘Scene’ preview text in compile have indentation removed it still remains in the compiled text. Also if I override document settings (this shouldn’t be necessary though, right?) in Section Layouts -> Formatting it also still remains. Hmm.

I’ve attached screenshots. The compile format scrformat is here.
dropbox.com/s/n1w14b436wblh … ormat?dl=0


Skærmbillede 2018-06-21 kl. 17.07.38.png
Skærmbillede 2018-06-21 kl. 17.06.59.png

You haven’t got a tab character at the start of the paragraph in the text, have you? Indents won’t remove tabs, but only ruler indents. If you have a tab at the start of the text, that will show up regardless. (Generally it’s better not to use tabs and only to use ruler indents.)

All the best,
Keith

No, only first line indents.
Skærmbillede 2018-06-21 kl. 19.33.07.png

Have you got a style applied to the text?

Strangely, the same document, compiled with Manuscript (Times) on iOS, correctly removes the indentation.

Manuscript (Times) iOS:

Manuscript (Times) macOS:
Skærmbillede 2018-06-21 kl. 19.43.07.png

Yes, I have my own style applied. I tried removing it and now it removes the indentation. Aha! So (how) can I have my own style and still remove the indentation? :slight_smile:

In general, it’s best not to apply styles to body text, but only to text that is different from the rest of the text. If you do want to have a style applied, though, then you will need to remove the indentation by overriding the style. To do this, in the “Styles” pane of Compile, add your style and then tick the “Flatten first indent” checkbox for that style.

All the best,
Keith

I’ve removed my own style and setup compile to reflects what I want … and it works (of course). Scrivener for the win. Thanks all! :smiley: