Removing unwanted indents (NOT at chapter beginning)

Hi, I read an answer to an earlier question about removing unwanted indents, but it didn’t completely answer my question. I’ll post part of the answer below so you will know what I’m referring to:

"2) Select the text without the indent and go to Format > Formatting > New Preset Selection and name it something like “Regular Text”.

  1. Do the same with the indented text and name it something like “Indented Text”.

  2. Use Mac OS X’s “Keyboard” section of the System Preferences to assign keyboard shortcuts to “Regular Text” and “Indented Text”. (You can find instructions on how to assign keyboard shortcuts here: literatureandlatte.com/wiki/ … _shortcuts )

Now you just type away and then when you come to type a quote you hit the keyboard shortcut for “Indented Text”. To return to regular text, you hit the keyboard shortcut for that."

I have certain paragraphs within chapters, (not the first paragraph) which I don’t want to indent. If I create a keyboard shortcut to do this, as specified above, will the program automatically resume indenting paragraphs? Or will I need to create a shortcut to tell it to resume them? The lines that shouldn’t be indented are fairly few so I don’t really want to have to hit a keyboard shortcut every time I want an indented paragraph, so I’m hoping it automatically goes back to default mode and starts indenting again.

Thanks!

Basically the text engine will go on using whatever formatting exists around the context where you are typing, and that includes insert carriage returns. So if the paragraph you are coming out of has an indent, the next one will as well. If you use the preset to remove the indent, the next paragraph will not have an indent. Thus you would only need to switch presets whenever things change.

Alternatively you can just let Scrivener handle this for you, if that works with how you are needing paragraphs without an indent. If you are using “Override text and notes formatting” in the Formatting compile option pane, you can click the Options… button and set Scrivener to remove first paragraph indents according to the criteria that works best for you. We have options for the most common options, so maybe one of those will work for you. For example you can have this happen after an empty line, often used to break a scene.

Yes - Scrivener continues paragraph formatting just as it does text formatting, that is, if you start italicizing or bolding text, your next text, and word, will be the same in italics or bold. So my personal solution to paragraph formatting is the same as the one to text formatting: if I want a word in bold, I will type the word, then a space, then back up and select the word only without the space and bold that. And with paragraph formatting, if I have a paragraph I want to center, I type that paragraph, hit return, then back up and center that paragraph. Or for a style such as you are using, back up and hit your key-shortcut. Then drop down to the next paragraph, which is blank and has inherited the formatting of your basic indented paragraph, and carry on.

  • asotir

Thanks so much for your answers. I don’t really understand the “Override text and notes formatting” in the Formatting compile option pane, so I tried the keyboard shortcuts. I highlighted a paragraph that wasn’t indented and named it, then gave it a shortcut, per the instructions. I did the same for a paragraph that was indented. When I went into my manuscript and highlighted a paragraph where I wanted to remove the indent, and hit the shortcut, it deleted my paragraph entirely and left a small symbol, like an “o” and “e” stuck together. I’m hoping you can tell me what I’m doing wrong!

Thanks.

It sounds like you may be using a keyboard shortcut with just Option or perhaps Shift and Option. You should know that these two keys are reserved by the text engine for the insertion of symbols. Try hitting Shift-Opt-K to see what I mean. This is just a global  Mac thing.

You’re right and now it’s working great! Thanks so much!