Replace All Wreaks Havoc!

I found something strange. While typing in Scrivener in fullscreen mode, I eventually decided that I didn’t like the main charater’s name and did a Find and Replace, using Replace All to change all occurrences of the name.

After I did that, I found that for some reason the last two paragraphs I had written had been deleted. I hit command-Z to undo, but while it DID undo the name changes, it did NOT restore the deleted paragraphs. So I hit Undo again, but nothing happened, and when I went to the Edit menu Undo was grayed out. So those paragraphs were forever lost…until I retyped them.

So a couple of paragraphs were lost. Big deal. But then, a while later, I decided I still didn’t like the name, so I did Replace All once again. And again, the last couple of paragraphs I had writted were deleted. I tried Undo, but it did not restore them no matter how many times I tried to Undo.

And then the REALLY weird thing happened. I hit Escape to exit fullscreen mode, and lo and behold, the ENTIRE section I had been working on was gone!

I tried switching to other sections and switching back, no luck. I couldn’t Undo. Finally I closed the entire document, and when I reopened it the lost section was back! All but the last couple of paragraphs, that is…

I tried to reproduce it by typing a short story featuring a fellow named Bubba. After a few paragraphs, I did Replace All to change the name to Cletus. It seemed to work okay.

Then I wrote a few more and changed the name to Harry. This time, it only changed the last couple of instances of Cletus to Harry, and when I exited fullscreen the whole story was gone. After closing and reopening the project, however, it was back. I couldn’t make it delete the last couple of paragraphs again, though, but it may have had something to do with the length of the story.

P.S. This also happened when not in Fullscreen mode.

EDIT: One more thing. When I tried to reopen the Bubba project after closing it, Scrivener crashed. When I reopened Scrivener and then the Bubba project, the section was still intact. This only happened once out of several attempts, however.

Clearly this sounds like a bug, though I need a little more info. :slight_smile:

When you say “Replace All”, do you mean Find > Project Replace or Find > Find & Replace All (the former applying to the whole project, the latter applying to the current document). Project Replace warns you that the replace cannot be undone, so perhaps you are talking about the latter?

Could you reproduce this bug? For instance, could you create a test project in which this bug occurs which you could send me so that I can test it and fix it? Or could you give me exact, step-by-step instructions on how to reproduce this bug on a new project? I have used and tested Replace All on a number of projects and never had a problem, so more info would be greatly appreciated.


I will you exactly how to reproduce this bug.

I created a new project called Bubba.scriv.
In the Untitled document, I typed this:

Bubba got up.
Bubba ate a moldy burrito.
Bubba got sick.

After that, I hit Command-F to bring up the Find window (not Project Replace). Then I told it to find Bubba and replace it with Cletus, and clicked ‘Replace All.’ Bang, it did it. I closed the Find window.

Then I typed this:

Cletus had to go to the hospital.
Cletus had his stomach pumped.

Then I hit Command-F again. This time I told it to find Cletus and replace it with BillyBob, and hit Replace All. And it worked. But THEN I told it to find BillyBob and replace it with William (without closing the Find window first), and nothing happened! I closed the Find window, and found that I couldn’t insert my cursor into the document. I clicked on Draft, and then back on Untitled, and all of the text was gone.

At this point I closed the project and then double-clicked on Bubba.scriv. Scrivener crashed. I reopened Bubba.scriv, and the text was there, with William in place of the last BillyBob (but the other BillyBobs were not changed). I did all this without trying to Undo, as I had before, so I repeated the above while trying to Undo the changes. The Undo worked fine. I have still not been able to reproduce the strange deletion of text I experienced before.

I also tried closing the Find window between replacing Cletus with BillyBob and BillyBob with William, but it still blew up.

Here is the crash log, if it helps:

Host Name: CaptainNapalm
Date/Time: 2007-02-26 15:26:33.962 -0700
OS Version: 10.4.8 (Build 8L127)
Report Version: 4

Command: Scrivener
Path: /Applications/Write/
Parent: WindowServer [61]

Version: ??? (1.01)

PID: 249
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0x6f634944

Thread 0 Crashed:
0 libobjc.A.dylib 0x9f7a7100 objc_msgSend + 32
1 …iteratureandlatte.scrivener 0x0009f07c -[SCRSearchResultsController labelAndStatusSettingsDidChange:] + 56
2 0x90afead8 _nsnote_callback + 180
3 0x902d7010 __CFXNotificationPost + 368
4 0x902cf0ec _CFXNotificationPostNotification + 684
5 0x90ae8ee0 -[NSNotificationCenter postNotificationName:object:userInfo:] + 92
6 …iteratureandlatte.scrivener 0x0000486c -[SCRMainDocument readFromFileWrapper:ofType:error:] + 1816
7 0x926c2950 -[NSDocument readFromURL:ofType:error:] + 644
8 0x92837b24 -[NSDocument _initWithContentsOfURL:ofType:error:] + 148
9 0x926c1e08 -[NSDocument initWithContentsOfURL:ofType:error:] + 264
10 0x9283e6b4 -[NSDocumentController makeDocumentWithContentsOfURL:ofType:error:] + 332
11 0x9283e4f4 -[NSDocumentController openDocumentWithContentsOfURL:display:error:] + 340
12 …iteratureandlatte.scrivener 0x000189e0 -[SCRAppDelegate application:openFile:] + 400
13 0x92504070 -[NSApplication _doOpenFile:ok:tryTemp:] + 388
14 0x9273c04c -[NSApplication _doOpenFiles:] + 224
15 0x9273bf44 -[NSApplication(NSAppleEventHandling) _handleAEOpenDocuments:] + 88
16 0x92508640 -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 296
17 0x90affae4 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 380
18 0x90aff944 _NSAppleEventManagerGenericHandler + 92
19 0x914f2960 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned long, unsigned char*) + 208
20 0x914f27fc dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 44
21 0x914f2654 aeProcessAppleEvent + 284
22 0x9201deb0 AEProcessAppleEvent + 60
23 0x92506cbc _DPSNextEvent + 856
24 0x925067a8 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 116
25 0x92502cec -[NSApplication run] + 472
26 0x925f387c NSApplicationMain + 452
27 …iteratureandlatte.scrivener 0x00002d5c _start + 760
28 …iteratureandlatte.scrivener 0x00002a60 start + 48

Thread 1:
0 libSystem.B.dylib 0x9002bbc8 semaphore_wait_signal_trap + 8
1 libSystem.B.dylib 0x900306ac pthread_cond_wait + 480
2 0x90b06300 -[NSConditionLock lockWhenCondition:] + 68
3 0x925a3708 -[NSUIHeartBeat _heartBeatThread:] + 324
4 0x90aff194 forkThreadForFunction + 108
5 libSystem.B.dylib 0x9002b508 _pthread_body + 96

Thread 0 crashed with PPC Thread State 64:
srr0: 0x000000009f7a7100 srr1: 0x000000000000f030 vrsave: 0x0000000000000000
cr: 0x44004244 xer: 0x000000002000001a lr: 0x000000000009f07c ctr: 0x000000009f7a70e0
r0: 0x0000000000525e38 r1: 0x00000000bfffdba0 r2: 0x000000006f634944 r3: 0x000000000577c140
r4: 0x00000000000c99ac r5: 0x000000000404d950 r6: 0x00000000bfffdcc4 r7: 0x0000000000000000
r8: 0x00000000bfffdcb0 r9: 0x0000000000000004 r10: 0x00000000000e6e0c r11: 0x00000000fff299ac
r12: 0x0000000000437740 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
r16: 0x00000000000ed0fc r17: 0x0000000000000000 r18: 0x000000000404d950 r19: 0x0000000005748ad0
r20: 0x00000000000e3d2c r21: 0x00000000a0286eb0 r22: 0x000000000000001b r23: 0x0000000000000000
r24: 0x0000000000405cb0 r25: 0x0000000000000000 r26: 0x0000000000000000 r27: 0x00000000040351e0
r28: 0x0000000004420020 r29: 0x0000000005748ad0 r30: 0x0000000000000000 r31: 0x0000000005706ca0

Binary Images Description:
0x1000 - 0xe2fff com.literatureandlatte.scrivener ??? (1.01) /Applications/Write/
0x12a000 - 0x137fff org.andymatuschak.Sparkle ??? (1.1) /Applications/Write/
0x4989000 - 0x49a2fff GLDriver /System/Library/Frameworks/OpenGL.framework/Versions/A/Resources/GLDriver.bundle/GLDriver
0x49f0000 - 0x4a58fff com.DivXInc.DivXDecoder 6.4.0 /Library/QuickTime/DivX Decoder.component/Contents/MacOS/DivX Decoder
0x4a65000 - 0x4b74fff GLEngine /System/Library/Frameworks/OpenGL.framework/Resources/GLEngine.bundle/GLEngine
0x4ba3000 - 0x4cecfff 1.4.18 (4.1.8) /System/Library/Extensions/ATIRadeonGLDriver.bundle/Contents/MacOS/ATIRadeonGLDriver
0x4cf6000 - 0x4d11fff GLRendererFloat /System/Library/Frameworks/OpenGL.framework/Versions/A/Resources/GLRendererFloat.bundle/GLRendererFloat
0x8fe00000 - 0x8fe51fff dyld 45.3 /usr/lib/dyld
0x90000000 - 0x901bcfff libSystem.B.dylib /usr/lib/libSystem.B.dylib
0x90214000 - 0x90261fff 1.0.2 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreText.framework/Versions/A/CoreText
0x9028d000 - 0x90366fff 6.4.6 (368.27) /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x903b1000 - 0x90688fff 681.7 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore
0x906ee000 - 0x9075efff 1.4 (???) /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x908db000 - 0x908dbfff 10.4 (???) /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
0x909f4000 - 0x90a7cfff 1.3.4 /System/Library/PrivateFrameworks/DesktopServicesPriv.framework/Versions/A/DesktopServicesPriv
0x90ad9000 - 0x90d04fff 6.4.6 (567.27) /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
0x90f5a000 - 0x90f82fff 1.8.3 /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
0x90fe3000 - 0x90ffbfff 1.1.2 (1.1.0) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/WebServicesCore.framework/Versions/A/WebServicesCore
0x9100b000 - 0x9108cfff 1.0.5 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchKit.framework/Versions/A/SearchKit
0x910d2000 - 0x910fbfff 10.4.4 (121.36) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Metadata
0x9110c000 - 0x9111afff libz.1.dylib /usr/lib/libz.1.dylib
0x91339000 - 0x913cafff 4.6 (177.13) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/PrintCore.framework/Versions/A/PrintCore
0x9141a000 - 0x91425fff libgcc_s.1.dylib /usr/lib/libgcc_s.1.dylib
0x9142a000 - 0x91432fff libbsm.dylib /usr/lib/libbsm.dylib
0x914ee000 - 0x914eefff 10.4 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
0x914f0000 - 0x91528fff 1.5 (297) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/AE.framework/Versions/A/AE
0x91543000 - 0x91610fff 4.4.4 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ColorSync.framework/Versions/A/ColorSync
0x918be000 - 0x918dffff 1.6.1 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LangAnalysis.framework/Versions/A/LangAnalysis
0x918f3000 - 0x91918fff 1.5 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/FindByContent.framework/Versions/A/FindByContent
0x91989000 - 0x9199dfff 3.3 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/SpeechSynthesis.framework/Versions/A/SpeechSynthesis
0x91ab6000 - 0x91c71fff 4.5 (28992) /System/Library/Frameworks/Security.framework/Versions/A/Security
0x91df1000 - 0x91e33fff 181 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/LaunchServices
0x92013000 - 0x92320fff 1.4.8 (???) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox
0x92470000 - 0x924cefff 1.5.3 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/HIServices.framework/Versions/A/HIServices
0x924fe000 - 0x92b31fff 6.4.7 (824.41) /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
0x92ef4000 - 0x92ef4fff 10.4 (???) /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
0x92ef6000 - 0x92f0afff 3.0 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/ImageCapture.framework/Versions/A/ImageCapture
0x92f22000 - 0x92f32fff 3.4 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SpeechRecognition.framework/Versions/A/SpeechRecognition
0x92f3e000 - 0x92f53fff 2.0 (203) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SecurityHI.framework/Versions/A/SecurityHI
0x92f65000 - 0x92fecfff 101.2 (69) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Ink.framework/Versions/A/Ink
0x93000000 - 0x9300bfff 1.0.3 (32) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Help.framework/Versions/A/Help
0x93015000 - 0x93042fff 1.2.5 (???) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/OpenScripting.framework/Versions/A/OpenScripting
0x9305c000 - 0x9306bfff 5.2 (192.4) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Print.framework/Versions/A/Print
0x93077000 - 0x930ddfff 1.1.2 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HTMLRendering.framework/Versions/A/HTMLRendering
0x9310e000 - 0x9315dfff 3.4.4 (3.4.3) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/NavigationServices.framework/Versions/A/NavigationServices
0x9318b000 - 0x931a8fff 3.9 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CarbonSound.framework/Versions/A/CarbonSound
0x931ba000 - 0x931c7fff 1.2.2 (73) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CommonPanels.framework/Versions/A/CommonPanels
0x933b7000 - 0x933ccfff libcups.2.dylib /usr/lib/libcups.2.dylib
0x9362c000 - 0x93638fff 1.4.7 /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
0x936b0000 - 0x936b0fff 6.4 (???) /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
0x94072000 - 0x940e2fff 80 /System/Library/Frameworks/CoreData.framework/Versions/A/CoreData
0x941cb000 - 0x94259fff 418.9 /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit
0x94439000 - 0x94476fff libsqlite3.0.dylib /usr/lib/libsqlite3.0.dylib
0x9447e000 - 0x944cefff libGLImage.dylib /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLImage.dylib
0x94671000 - 0x94680fff libCGATS.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCGATS.A.dylib
0x94688000 - 0x94695fff libCSync.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCSync.A.dylib
0x946db000 - 0x946f4fff libRIP.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libRIP.A.dylib
0x946fb000 - 0x9495dfff 7.0.0 /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime
0x94d8c000 - 0x94e21fff libvDSP.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvDSP.dylib
0x94e47000 - 0x94eb5fff libvMisc.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvMisc.dylib
0x94ec1000 - 0x94f57fff 418.3 /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore
0x94faa000 - 0x952b6fff 418.21 /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore
0x95c01000 - 0x95c2afff libxslt.1.dylib /usr/lib/libxslt.1.dylib
0x95db8000 - 0x95df1fff 1.0 /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit
0x95e4b000 - 0x95e7dfff 1.0.1 /System/Library/Frameworks/Quartz.framework/Versions/A/Frameworks/PDFKit.framework/Versions/A/PDFKit
0x96317000 - 0x96358fff 4.0 (129.18) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork
0x9646e000 - 0x96553fff 2.4 /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.framework/Versions/A/vImage
0x9656c000 - 0x9661dfff ATS /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/ATS
0x972ee000 - 0x9730dfff 3.2.2 (vecLib 3.2.2) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/vecLib
0x9737a000 - 0x97399fff 3.2.2 (vecLib 3.2.2) /System/Library/Frameworks/vecLib.framework/Versions/A/vecLib
0x9740a000 - 0x9744cfff 1.5.0 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/ImageIO
0x9746c000 - 0x974dbfff libJP2.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libJP2.dylib
0x974f3000 - 0x97511fff libJPEG.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libJPEG.dylib
0x9758e000 - 0x9758ffff libGLSystem.dylib /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLSystem.dylib
0x97591000 - 0x9759efff 2.5.6 (AGL-2.5.6) /System/Library/Frameworks/AGL.framework/Versions/A/AGL
0x976c3000 - 0x976c6fff libRadiance.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libRadiance.dylib
0x976c9000 - 0x97728fff libRaw.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libRaw.dylib
0x9772e000 - 0x9776bfff libTIFF.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libTIFF.dylib
0x979a2000 - 0x97a65fff 1.4.3 /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
0x97ad8000 - 0x97cabfff 1.4.9 /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore
0x9825b000 - 0x9825bfff 1.0 /System/Library/Frameworks/Quartz.framework/Versions/A/Quartz
0x9885d000 - 0x9892efff 1.2.3 (32.21) /System/Library/Frameworks/Quartz.framework/Versions/A/Frameworks/QuartzComposer.framework/Versions/A/QuartzComposer
0x98a7c000 - 0x9920efff 7.0 /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents
0x9b17a000 - 0x9b19afff libmx.A.dylib /usr/lib/libmx.A.dylib
0x9e855000 - 0x9e916fff libGLProgrammability.dylib /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLProgrammability.dylib
0x9e941000 - 0x9e9b2fff libstdc++.6.dylib /usr/lib/libstdc++.6.dylib
0x9ea25000 - 0x9ea43fff libGL.dylib /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib
0x9ea4e000 - 0x9eaa8fff libGLU.dylib /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLU.dylib
0x9eac6000 - 0x9ebb4fff libiconv.2.dylib /usr/lib/libiconv.2.dylib
0x9ebb7000 - 0x9ec32fff 3.0.4 /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
0x9ec6f000 - 0x9ef9afff libLAPACK.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLAPACK.dylib
0x9efca000 - 0x9f552fff libBLAS.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
0x9f585000 - 0x9f585fff 1.2.2 (Accelerate 1.2.2) /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate
0x9f587000 - 0x9f5a0fff libPng.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libPng.dylib
0x9f5a5000 - 0x9f5a9fff libGIF.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libGIF.dylib
0x9f5ab000 - 0x9f673fff libcrypto.0.9.7.dylib /usr/lib/libcrypto.0.9.7.dylib
0x9f6c1000 - 0x9f6cafff 2.1 /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
0x9f6d1000 - 0x9f751fff 4.1 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices
0x9f79b000 - 0x9f7a0fff libmathCommon.A.dylib /usr/lib/system/libmathCommon.A.dylib
0x9f7a2000 - 0x9f826fff libobjc.A.dylib /usr/lib/libobjc.A.dylib
0x9f850000 - 0x9f907fff 3.10.21 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/QD.framework/Versions/A/QD
0x9f944000 - 0x9fcfefff 1.258.38 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics
0x9fd8b000 - 0x9fe8dfff libicucore.A.dylib /usr/lib/libicucore.A.dylib
0x9fee7000 - 0x9ffc5fff libxml2.2.dylib /usr/lib/libxml2.2.dylib
0x9ffe5000 - 0x9fff7fff libauto.dylib /usr/lib/libauto.dylib
0x9fffe000 - 0x9fffefff 1.4 /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit

Thanks. Haven’t tried it yet, but I’ve just copied and pasted your info to the 1.02 list of things to investigate.
Thanks again and all the best,

I just ran through the instructions and was unable to reproduce this problem in any way. Hopefully the crash log has something telling within it.

Thought maybe it was just my laptop, but I tried it on my Intel iMac and got the exact same results.

I also tried that exact sequence in TextEdit, but it did not happen there, so I don’t think it’s a problem with the OSX text system.

I tried something else, too. All the typing isn’t necessary. I just typed this:

Bubba ate a moldy burrito.

Then I hit Command-F and did the Replace All with different names. The first two times it worked fine, but the third time this bug showed up. It always happens on the THIRD ‘replace all.’

Interesting. I’ve managed to reproduce it. It seems that the third global replace using command-F doesn’t work. It just error beeps and is suceeded by some odd behaviour, screen redraw issues and an application crash.


As usual, I went on too long and then went back to the problem and discovered more. Skip way down to Edit/Edit if you want.

I’m having problems, too. I’m using an Inteil iMac.

I tried a “replace all” using the line “Bubba ate a moldy burrito.” The first time I chose replace all, Scrivener quit. I closed out, tried a second replace all and that one worked. I tried another replace all and nothing happened - no replacement, nothing.

This is hard to remember, because things happened too fast, but I did something, like try to go to another document and come back, and after I did, my text disappeared. I quit Scrivener and came back in and the text was there again, with the change made.

I closed out completly, came back and opened a new document with a new sentence. I replaced one word and it worked. I closed the find/replace dialog and reopened it, then tried to replace the replaced word with another. The “replace all” button depressed, but no change happened in the document.

The find dialog is acting funny now - I type in the word to change and a replacement word and the “replace all” button is grayed out. I close the dialog box and now it won’t open again and the application has locked up. I closed out of the program and went back in, and the change had been made.

Something else that’s odd. If I just use regular “replace”, the word is replaced. If I click on “replace” again with the find dialog box still open, the word I’m substituting is added to the text. If I hit replace again, the word is added again. I could do that all night, but I had to give up sometime.

To sum it up, various odd things happen, not always after the same number of repetitions and not always the same odd thing. I tried one more round of “replace all” and it worked just fine this time. Go figure.

I tried to do these things in Text Edit and it is working okay.

Edit: Keith, Maria and I had a problem once where we inadvertently created a new file and deleted it before we had named it. You said this caused an instability in the system, although it didn’t show up until later. This bug has the same flakiness to it. I don’t know if that helps, but maybe it will.

Edit/Edit: In a more controlled manner, I opened a new project and in the new untitled file, typed two sentences that contained several of the same words.

I replaced different words each time with new words and closed the find box after each set of replacements.

The first time or two, the replacements worked. The third time (or once, the second), nothing seemed to happen after I clicked on replace all (no changes to the text on screen.) When I exited Scrivener and came back, the changes had been made.

But … several times I made changes, only one of the words to replace was found and the other was missed. When I went out of Scrivener and went back in, the unchanged word had indeed remained unchanged.

I created new files between each group of find/replace actions and I exited Scrivener after I created the new files, just to be sure that had no effect on the problem.

In Text Edit, I did manage (once) to have it miss one instance of a word in a find and replace. I closed out and went back, and it still missed replacing that word. I couldn’t duplicate this, however.

A final note. I tried replacing a word without closing the find box in both Scrivener and Text Edit, then tried to replace the word I’d just replaced with another. That worked in Text Edit, but nothing seemed to happen in Scrivener. I closed out of Scrivener and went back, and one of the two instances of the word had been changed (the second one), but the first had not. In the problem I had with Text Edit, it was also the first instance that was missed.

Text Edit was able to make multiple replacements without closing the dialog box, but Scrivener never could.

And finally, I did manage to duplicate the Text Edit problem after a number of tries. Again, it was the first word that was missed - in this case, the first word in the document. It appears there may be some random bug in both, but it’s much worse in Scrivener and easy to duplicate there.