Replicable bug in scrivener opening

I was being irritated because scrivener began to always open maximized. My screens are rather large (I have 2) and I don’t work maximized with any program. I have windows 10 20H2. two screens. Every time I opened a project I had to switch from maximized to normal Window mode.

I had the OPTIONS > COMPOSITION MODE > BEHAVIORS > Set to open composition mode to current screen. Changing it to primary screen, where I used it most of the time, resolved the issue. It now opens in normal window mode.

If I reset the composition mode to current display instead of Primary Screen, then it goes back to always opening in maximized mode.

I haven’t tested what happens if I switch it to Secondary screen.

Obviously, it should open in the configuration it was shut down in.