Resetting chapter numbers with compile 'as is'

Hi, so I’m trying to compile a novel made of six parts into kindle ebook. I have six folders for each of my parts, and I have created title pages for these ‘as’ the folder, so I have ‘compile as-is’ chosen for them. This works well.

I then have my chapters as new files within these folders – pretty standard stuff. I have a compile setting for these, which uses auto chapter numbers, and that also works well. The only issue is the chapters for part one will go 1,2,3 as expected, but then part 2 will carry on (eg, 29,30,31) when I need them to restart at 1.

I have tried giving the first chapter of each new part a different assigned section and then using <$rst> before the chapter number, but this will only reset that first chapter of each part at 1 and the following ones continue from the original order (so part 2 now goes chapter 1, chapter 29, chapter 30, etc). I’m assuming this is because they’re all on the same ‘level’ still. Is there a way to get the chapters to reset without having to construct my parts in compile settings?


I’m trying to do this, too! Did you ever figure this out?

Try putting the reset command in the body text of the chapter you want to restart with, rather than in the Section Layout.


Thank you, Katherine! That worked, hallelujah! (why does this have to be so hard???)