resetting margins within a document

i want to change the margins within a manuscript to indicate a passage from a book. it is unclear to me how to do this.

Hit Cmd-R to reveal the ruler.


i can display the ruler and change the margins settings in the ruler, but it seems to have no effect on the document itself. i must be overlooking something stupendously obvious and simple.

Like highlighting all the paragraphs you want to change?

Or else, make sure the paragraph format is set the way you want it in the appropriate pane of preferences, and then on any document choose from the menu bar.



OK, i successfully changed margins and font for a selection and it looks great.

however, when i compile and then print, i am back to regular margins and the font is not used.


actually, i just realized that when i compile to print and print, i lose all formatting, including font selection.

what am i doing wrong now???

That’s kind of what compile is for; to smooth out all the margins and fonts, and allow you to change them all in one place instead of fixing formatting throughout the whole document. The easiest way to avoid the problem you’re having is it highlight the indented passage and select Format->Formatting->Preserve Formatting. It will put a line around the text, indicating that the text’s attributes will not be overridden during the compile process, which includes the margin settings.

Also of note, if you want to do this in multiple places, is to highlight that section again and select Format->Formatting->New Preset from Selection. Then when you want to set up another passage the same way, go to Format->Formatting->Apply Preset and select the one you created. This will apply that formatting, including the “preserve formatting” option, to whatever text you’ve highlighted.

OK, i think i understand that.

how do i set up the document initially for a specific font (and any other attributes). i thought making those selections at the start of the document (and seeing them on screen) was doing that. whatever happened to WYSIWYG?

i may need to take that back. on closer examination, i think the font is correct. sorry.

You can adjust your Scrivener Compile settings to not override the font if you like writing in the same one that you use for outputting to a document or the printer. The point is that you don’t have to; you can just focus on the words, and not so much on formatting.