Resize pop-out binder in full screen?

I’m enjoying the ability to just mouse over to the left to get my binder to pop out as needed, but I’m using some rather long titles in my research notes, and would like to drag the binder’s width out further. However, no matter how hard I try, I can’t get it to resize. I can get the mouse cursor to change to the resize symbol once I’ve clicked into the binder to keep it on screen. I just go to the very bottom of it, and the cursor changes, but it has no effect.

Is it possible to resize the binder like this?

Edit: I’m still on Lion, as my ancient MBPro is stuck in the flatlands, but am up-to-date in both system and Scrivener settings.

There’s no way to control this, no - both the binder and inspector are set to have a width equal to a fifth of the screen when they slide in, as this seemed optimal. Just for you, though, I’ve added a hidden preference, “BinderSlideInWidth”, for the next update. You’ll need to set the value using the “defaults” command in the Terminal, but it will do what you want. :slight_smile:

“Very well, Mr. Blount. The photos and the negatives will be in the mail once you deliver,” he said, twirling his mustache.

Just for me TOO!!! This is exactly what I want also!!!
Thanks!!!

As I said, above, I’ve added a hidden preference!! You can check it out in the new beta!! :smiley:

It took me forever to find this post again after upgrading. The upgrade looks nice so far! Please tell me how to do this resize, or where to find the directions if they are posted somewhere!!!
Thanks!!

It’s a hidden preference, which means that you need to open the Terminal.app and type a couple specific lines in there to set this. Section D.4.11 in the user manual is the one you want.

Thanks for the quick reply Jennifer!!!

I know this goes in terminal, but I have only used terminal a few times.

Can I just cut and paste that in, and give pixels a number, or is there something else I need to do?
Is inspector width just replacing the word binder with Inspector?

If I do something wrong will my computer begin to smoke? :frowning:

Yes, just copy and paste the text from the user manual and replace PIXELS with the number of pixels you want. Be sure that you have quit Scrivener before doing this. I’m not aware of an option to change the width of the slide-in inspector; this is just for adjusting the binder width. You can still display the inspector regularly as part of the window and adjust its with even while keeping the binder slide-in, so if you need a wider area for the inspector that’s probably what you’ll want to do. You can toggle it to hide again when you don’t want it with the Opt-Cmd-i shortcut.

Your computer shoudn’t go up in smoke, but do note that working with Terminal does open up the opportunity to make some potentially disastrous mistakes if you’re not careful about what you type there. If you just copy and paste the text for this preference exactly as it is in the manual, you should be fine. When you want to get rid of it, open up the Terminal again and enter

defaults delete com.literatureandlatte.scrivener2.plist BinderSlideInWidth

Jennifer,
Thanks for the thorough reply!!!
I tried this many times, even typing it by hand, and it never changed the full screen Binder width when automatically sliding out. Is there a chance the update disabled this!!!

No, it’s definitely in the latest version. Are you getting an error message in Terminal when you try to set the width? What number are you using? This may be way too large, depending on your screen size, but try the following:

defaults write com.literatureandlatte.scrivener2.plist \ BinderSlideInWidth 1000
Then open Scrivener and open a project to Full Screen–does that work?

Jennifer,

I don’t know what to say!! It still doesn’t work! weird!!!

My computer is a fifteen mac pro retina, I have os x updated, and scrivener is fully updated. I made sure to close scriv. and then opened and went to full screen afterwards, and it still comes out the same short distance. I typed it many times and checked for any differences or errors many times. I received no error message or any other message after entering the code. It simply entered and showed a new entry line.

If you have any other ideas please let me know, otherwise don’t worry about it, I am sure you have plenty to do like the rest of us, Thanks!!!
John

Does this look Right???

Last login: Tue Mar 26 09:46:06 on console
Johns-MacBook-Pro:~ JGO$
Johns-MacBook-Pro:~ JGO$ defaults write com.literatureandlatte.scrivener2.plist \ BinderSlideInWidth 1000
Johns-MacBook-Pro:~ JGO$ defaults write com.literatureandlatte.scrivener2.plist \ BinderSlideInWidth 1000
Johns-MacBook-Pro:~ JGO$
Last login: Tue Mar 26 10:37:14 on ttys000
Johns-MacBook-Pro:~ JGO$ defaults write com.literatureandlatte.scrivener2.plist \ BinderSlideInWidth 1000
Johns-MacBook-Pro:~ JGO$
Last login: Tue Mar 26 11:01:06 on ttys000
Johns-MacBook-Pro:~ JGO$

That looks normal. UNIX doesn’t tend to say much unless something goes wrong, because it was designed to be streamed over super slow serial lines and networks. Each letter counts. What OS X version are you running by the way? Are you definitely doing this with Scrivener closed?

I am running Mountain Lion and it’s completely updated. Scrivener is also updated, and it looks different so it appears to have taken. When I first did the update it looked different and the app store still listed the update as needing to be done. I did it again and now it no longer shows in the update list. That was weird! Also, I did the update only two days ago so could make sure most of the bugs were caught first. I went straight to the latest and past the one that caused a resubmission to the store.

I definitely close Scrivener first, before trying to change the defaults.

You know what, I’m not sure if the defaults command even works with MAS applications. They have to use their own little universe for preferences, rather than the standard shared library approach. So it may well be you have a prefs file in ~/Library/Preferences with nothing in it but this one preference, and the MAS version does not have permission to use it.

Yeah, I just tested it with a vanilla account using only the MAS version of Scrivener, and the change is applied to the shared preference file, resulting in a .plist file that has one instruction in it. The rest of the preferences are off in ~/Library/Containers/com.literatureandlatte.scrivener2/Library/Preferences. Reading the man page for defaults seems to suggest they never built a way to handle this.

Do you have XCode installed? If so you can edit .plist files directly. There are a few dedicated plist editors out there, too—that might be the best approach (as XCode is a rather huge thing to install for one little tweak).

When this thread was open before, I gave up getting this to work for me since i had the app store version, and it would not allow me to make the binder slide out further in full screen. I now have a new computer, same, but new, and I have a large display. I still can not get this to work, and I really put effort into making sure I did this correctly, and I used many sizes, even larger sizes.

I also now have the downloaded version which this should work with. I activated it by first downloading the app store version, and then the website version so it could see my app store registration. This worked to register it, when before downloading the app store version and erasing it before downloading the normal version did not allow it to register. Ugh, hope that makes sense, it’s late.

I wonder if I need to erase it and reinstall it, but then registration does not work!

Suggestions?

The only thing you really need to be sure to do when setting up a new system is to launch the MAS version at least once after installing. If you just install it and then promptly delete it, Apple’s system won’t register the copy. Running it will place your proof of purchase information into your library folder where the direct-download version can find it.