Retention of current location across Scrivener sessions

I believe I’m seeing the following behaviour in Scrivener:

  • Screen layout and current document/scrivening/outline
    being viewed in each window are retained between sessions
  • Current viewing/cursor position within document is retained,
    but current viewing/cursor position within scrivening is not retained
    (are just presented with the top/start of the scrivening)
    And believe I’m seeing that same behaviour when toggling
    next/last for a given window.

Naively, I think I would like for current viewing/cursor position
within scrivening to be retained and presented,
rather than top/start of the scrivening,
as I tend to write and review within scrivening windows
rather than individual document windows.
Don’t know how practical that would be.

Am I missing something or is this worth considering adding?

If not, what’s the best alternate/workaround?

The first that comes to mind is to mark the current spot
I’m at within a scrivening by selecting the text
so is highlighted, then, at start of next session,
scroll down from the top of the scrivening
and find the highlight, which is retained.

Thanks.

This may be due to the current way that Scrivenings works, so I’m not sure if it’s immediately fixable, but we’ll call it a bug, because what ought to happen is that the insertion point location is remembered and scrolled to when you reopen the project. At present, the insertion point position is retained separately for each document in the session, and that is probably causing this other problem of the session scrolling to the top, because the insertion point position in that document is the first it sees.

Making a bookmark location before you close the project might be a simple way to work around this. You could use some memorable but unique letter combo for this (something that won’t otherwise appear in the text) and then at the start of your session just use Ctrl+F to bring up the Find dialog, enter your term, and jump straight to your bookmark, then delete it and proceed with work. You may want to place the bookmark term in an inline annotation, so that it is less likely to end up accidentally left in your text–it will be more visible, and in compile they’re likely either being stripped out or converted to margin comments. You can use Ctrl+Shift+A to toggle the inline annotation formatting on before you type your bookmark word.

This must be a common problem, because when I load up my current project (in full screen mode) on my Mac, the Scrivenings session in the editor scrolls back to the top of the first document (the folder’s text, actually).

If this can be fixed in the Windows version, it’d be nice to also fix on the Mac.

If it can’t be fixed, then at least we’re all in the same boat. :slight_smile:

This definitely should be working on a Mac to return the focus to wherever you left the insertion point in the Scrivenings session, but there are some notorious Full Screen issues that may still be causing problems. How do you have the editor set up for Full Screen?

Great googly moogly… so many tweaks.

I think the most relevant settings are:

  • I quit Scrivener/close the project while in full screen when I’m done each day
  • I do NOT have the binder & inspector auto-hiding at the moment (but did previously)
  • both Binder and Inspector are visible
  • Split editors (scrivenings session on top, cork board view of another folder on bottom)
  • Auto-hiding the toolbar.
  • The folder I have selected for the scrivenings session is set to show it’s text contents, and it does have text in it.

Every time I start up scrivener, I usually start by opening the project directly from the Finder without having first launched Scrivener. When it opens the project and enters full screen, it displays the folder text as if I had scrolled to the top of the scrivenings session. The cursor, however, does appear to be where I left it last, so if I use the cursor keys, it immediately scrolls to that position in the editor if I happened to have left the focus in the editing session when I quit last time.

Edit: One more detail. I usually go forward in the editor’s document history to a document where I record word counts and other stats for the day, and then click back to the Scrivenings session before I quit. When I do that, I end up where I was in the editor before (usually scrolled all the way to the bottom, and the cursor is still in it’s place.

Also add to the list of settings above:

  • Typewriter scrolling is OFF

Addendum to my Edit: I’m using the current beta, build 24052. Should I just copy this report to the beta bug forum? I’m pretty sure this issue was present in the release version, but for obvious reasons, I can’t verify that.