Revision behaviour changed

Not sure if this is a feature or a bug but finding it annoying.

Previously, after revisions, you could remove all the revision colours by selecting text and then “remove all revisions” from the revision menu and it all reverted to black. This worked whether, at that point, revisions were active or not.

In the new beta I can’t do this. The only way I seem to be able to remove my revision colours is be selecting the revision colour I want to remove and then using “Mark as revised” the other commands now don’t seem to do anything. This means to revise a document with multiple revision colours I’d have to treat each one separately.

I’m looking at revisions created in previous BETA version so don’t know if behaviour would be different for revisions crated in that version - but it seems to make accepting revisions much more complicated.

Think I’ve solved this myself by digging around in the manual.

I’d changed the revision colour defaults since making the initial revisions and it looks as if the system is using the specific colour to identify the revision and so was no longer able to recognise my original revisions as such and reset them as I’d changed the defaults.

I’ve typed some new revisions into the new Beta and it does work as expected.

Indeed, your findings are correct. For Mac compatibility reasons, the revisions levels are now color specific. If you change the specific level revision color, your old revision level will be no longer detected. We are aware of all the complications which this might raise, unfortunately because of Mac compatibility we had to degrade the functionality here.

The main benefit of this approach is that you can edit and import revisions from external editors, when you use the same text colors.