Right Indent problems in M. Word with v2.3 (19120)

Since I updated to v2.3, my manuscript overflows past the right side of the M. Word page. I didn’t have the problem before the upgrade.

I’m compiling to RTF and have the right indent in the Scrivener editor set as far right as I can. The page margins are set to one inch all around in the Compile settings.

I’ve tried pulling the right indent to the middle of the page and get the same result.

For what it’s worth, I notice that when I drag the right indent all the way to the right, it “bounces” back out a quarter inch or so – it doesn’t remain all the way to the right. I don’t recall if this behavior is normal and that I haven’t noticed it before. Regardless, the compile is behaving as if I don’t have the right indent turned off.

Also for what it’s worth, if I open the RTF doc in TextEdit, the margins are what I expect. Unfortunately, using Text Edit isn’t a workaround for me because I am pasting the text from the word processor into Mail and I lose line spacing when I do that from TextEdit.

The net of all this is that my ms needs a lot of manual work when opened in Word.

I keep thinking I’m missing something obvious, but for the life of me can’t find a way around the problem.


It sounds to me as though you are doing the right thing. When you pull the right-indent marker all the way to the right, it will bounce a bit like you describe (it’s always done that), and that is your indication that it has been disabled and is not actually set to a value that happens to be as wide as your screen (the other indication is that if you resize your window or dialogue box, the marker floats with the width rather than staying stuck at a certain spot). So it sounds to me, since you say it is fixed in the compiler, that you are indeed using “Override text and notes formatting” in the Formatting compile option pane? Whatever is set in the editor then, doesn’t matter and you are generating a uniform format in the compiler? If so the first thing to check is the Options button. Make sure tab stops and indents are in fact actually being overridden. It is possible to instruct the compile to selectively ignore certain types of formatting when overriding, and perhaps that one got turned on accidentally.

Next thing to check is each formatting rule that has the “Text” checkbox ticked. Just make sure and drag the indent all the way to right until it bounces, after you’ve clicked somewhere in the fake text area.

Not that this solves the problem, as we need to get your RTF fixed first, but a vastly preferable way of submitting chapters is to attach the RTF file itself, rather than pasting it into an e-mail client. E-mail isn’t really designed to convey typeset documents—chances are high that no matter how much care you put into the look of it on your end, the recipient is seeing something entirely different—perhaps even plain-text and is missing all of your italic and other markings.


This sounds like a bug that came to my attention a couple of days ago. Could you please try this version of Scrivener and let me know if it fixes the issue for you:

literatureandlatte.com/dlbet … 3Fixes.zip

Note that this version will only run on 10.6 and above, so let me know if you are on an earlier system.

Thanks and all the best,

Thanks Keith, I was meaning to bring this to your attention this morning as I’ve come across a few other cases of right margin overrun after an update.

Hi there,
I’ve been having the same problem as hopkinsje with the text running off the right side of the page when I export a file to MSWord. The “fix” version here does fix the problem mostly – for the main body of an essay. But the text still runs off the page for all of the parts of the document that were in the preset format “Essay Block Quote (Preserved)”.
Thanks for any help!


I can’t reproduce this, I’m afraid - “Essay Block Quote (Preserved)” works fine for me in exported Word documents. Could you please send me a sample project that shows the bug, zipped up, to mac.support AT literatureandlatte DOT com?


All the best,

I was having this same problem. The “23fixes” binary you linked to above fixed it for me.


Great, thanks for taking the time to post, too - it’s always good to have as many confirmations as possible that a bug-fix is working. This will be rolled into an official update in the next few days that also adds full Mountain Lion compatibility.