Right indents and separators

I tried using a few stars as a separator (in Compile options) and noticed they don’t all align on the same center. Looking closer, I saw that some (most) documents have a right indent tab in the ruler but others (two lines at the start of each chapter) do not. Reading the manual on right indent tabs, I see that I’m better off not using them. So I have a few questions:

  1. How could I get rid of all those right indent tabs at once?

  2. Is it one ruler per document, or one ruler per paragraph?

  3. What is the centered separator using as its center point in the two cases – with and without right indentation?

  4. I LOVE the separator I see in Scrivening view. It’s a long centered line that’s slightly thicker in the middle. Can I get that effect in Compile? Can I put some kind of centered graphic there instead?


Check in the Formatting pane first, and see if the “Override text and notes formatting” at the top is enabled. If so, just flip through any of the lines in that list at the top that have a checkmark in the Text column and examine the ruler for each. If you find the offending tab stop, remove it and you should be all clear.

If you aren’t using override formatting, then the problem is coming from any of the individual text documents in the binder. Since you have the problem narrowed down to two cases, you probably know right where to go to check for problems. Ruler are per-paragraph by the way.

No, there isn’t any capacity for that. It should be possible in theory as we now have an image placeholder tag (which can be used in the Formatting title prefix/suffix; but that won’t work as a separator). So I’ll see if that capability can be added.

Specifically on the Scrivenings separator, that might not work as well in print. It depends on the type of book of course—if it is an art book with glossy pages and full colour graphics then that another matter entirely, but most are going to use a much more economical printing method that would end up causing subtle gradients like this to come out splotchy with visible dot patterns—think black & white pictures in a newspaper. Solid glyphs are much safer to use. There are a lot of cool things you can do with Unicode characters in the Separators pane.

Override IS checked in the Formatting Pane, I see a right-indent in ALL the rulers, and I’m unable to remove any of them. I thought I could drag it off the ruler, but that doesn’t work.

I can’t remove right indents in my text documents either … but now I’ve noticed the epigraphs that begin each chapter don’t have paragraph marks. When they do, I get more space after them than I want. Lacking paragraphs, these documents also don’t have rulers, hence no right indents, and that’s a source of the difference I’m seeing in centered separators.

I suppose I could remove ALL the tabs on some paragraph, add back those I want, and make that the default text style … but if I did that, would it affect text that I’ve marked to “preserve formatting”?

I can’t see myself manually removing the right indent from hundreds of paragraph rulers one at a time … especially since I can’t remove even ONE.

Are we talking about the right indent or a right tab stop? Assuming the former, the marker on the ruler won’t ever disappear completely, but when you drag it all the way off to the right, it should attach itself to the right edge of the ruler and move with the ruler if you make the window wider or narrower. This means it’s just fixed to the right margin, which is typically what you’ll want. A tab stop can be dragged off the ruler up or down to remove it and it will then completely disappear.

Are the epigraphs in their own document in the binder? I’m not sure I completely follow this, but I’ll assume you’ve got each set up as its own document and the epigraph is a single paragraph, with no additional empty lines before or after it in the editor (so, if you turn on Format > Options > Show Invisibles, you won’t see any paragraph markers). There is still going to be a ruler associated with the epigraph text, but depending how you have your binder structured and your compile formatting options set, you may have different settings for the epigraph documents and the rest of your scene documents–for instance, if the epigraphs are document groups with the rest of the chapter as individual scene sub-documents below it, the epigraphs would follow the formatting rules for doc groups and the scenes would follow the rules for single documents. What level the documents sit at in the binder hierarchy could also be making a difference.

Maybe a few screenshots would be helpful here, showing the ruler for documents that are compiling properly and those that aren’t, and perhaps a sample of your binder structure (you can blur out titles if you want) and the formatting table in compile? That might help make sure we’re addressing the right issue.

Also, just a thought–while the ruler settings are specific to an individual paragraph, this isn’t entirely the case for how things work in compile. Compile formatting will treat all of a document’s text the same, so when you adjust the ruler for, say, Level 1+ single documents, you’re going to be applying that ruler setting to every paragraph in each single document, regardless of how you might have formatted individual paragraphs in the editor. There are exceptions: documents marked “compile as-is” of course ignore this, and you can further exclude certain paragraphs with Format > Formatting > Preserve Formatting and the compile options at the top right of the formatting pane. But generally speaking, if you’re overriding formatting, you’re working at the document level rather than the paragraph level.

OK, looking further, I found Format>Text>Remove all Tab Stops – which simply doesn’t work. Or at least, it doesn’t affect left, right, or hanging indents. Indents and tabs are two separate things, I suppose.

And I found Format>Text>Indents>Increase right indent … which didn’t increase the right indents, it REMOVED them. I suppose that’s because they were already close to the maximum … not all THAT close, though. Removing them is what I wanted, however, so … that’s good for now.

It gets even MORE murky. The original problem was that some separators centered on a different position than others, and I thought the difference was due to right indents. But I’ve removed right indents from three consecutive documents – all three have the same ruler now – and STILL the separators have different centers on Compile.

Each chapter is a folder. The first document in the folder is an epigraph; the second is a tag-line that says where the chapter occurs and whose POV is used. The following documents are scenes within the chapter. The epigraph and tag-line use “preserve formatting” and have no paragraph marks. In the example I’m looking at, the epigraph is centered.

When I compile (with override formatting selected), the result is

I won’t really WANT these separators, but I may need others somewhere, and if they center haphazardly … I can’t used them.

They are right indents, I can NOT drag them to the right until they attach themselves to the right edge of the ruler, but I CAN make them disappear completely, using Format>Text>Increase right indent.

Ok, it looks like the problem is that you do have a right indent set for your epigraph and due to the preserve formatting, it’s being kept through the compile process (since it is exempt from the override). When you use the Increase Right Indent, you’re actually setting an indent–it’s not being removed, it’s just being set to a number on the ruler that is off the visible space in the editor (i.e. the editor is not as wide as the indent is set to, thus you don’t see it on the ruler).

There are a few ways you could fix this, but probably the easiest is to click the Options button in the top right of the Formatting table in compile and then at the bottom of the panel that pops up check the boxes for “Preserve Formatting Only Preserves”, “Alignment” and “Line Spacing” (also “Font Size” if you want it). That will keep the epigraph text centered and with the greater line spacing but will ignore the indent settings, meaning the text and the separator should be properly centered between the actual page margins when you compile.

If that doesn’t work for you because you need to preserve tabs and indents for other text that has Preserve Formatting applied, you’ll need to reset the right indent marker for each of the epigraph documents that is causing the problem. If you make your editor wider, you should be able to see enough of the ruler to grab the indent marker and slide it all the way off to the side; otherwise, an easy way to do this is to create a new dummy paragraph that has the ruler settings you want for the epigraph and then use the Copy/Paste Ruler commands to apply those settings to the epigraphs. You can load multiple documents in a Scrivenings session and then use Select All to apply the ruler adjustments to everything at once.

I’m getting there, with a combination of those suggestions and others.



I still want the scrivenings separator in Compile, though.