Rolled back to 1.7.2

I was having minor redraw problems with Scriv. When I checked my version it said I had an old version (1.7.2) and should update. I did, but after updating to 1.8.6 the program because unsuable (would not even launch). At that point I submitted a ticket to Support and went back to version 1.7.2. ~ Support urged me to get rid of everything and reinstall 1.8.6 again, which I did. Unfortunately that didn’t solve the issue.

Anyone have a link to where I can get 1.7.2 again? The URL in the ReadMe (“Previous versions, change and bug fix lists are available from: … geList.php”) doesn’t seem to lead to any way to download.

Fortunately I had a restore point from last July, which I am clinging to for the moment.

I couldn’t find your email in support, so I’m not sure what you’ve done already for addressing the issue; apologies if this is just repeat. If you haven’t tried adjusting the compatibility settings for Scrivener.exe, give that a try. It shouldn’t be necessary, but it’s made a difference for a few people having a problem of Scrivener not starting. Possibly some recent Windows update affected some system configurations. To set compatibility mode, right-click on the Scrivener.exe file in the installation folder and choose Properties, then “Compatibility” and check the option to run the program in compatibility mode. You can play with the options there to see if you get different results, but even setting compatibility for Windows 7 while running Windows 7 can get things working.

If that doesn’t seem to do it, try using Microsoft’s msconfig tool to disable all your startup items and reboot to test launching Scrivener in a cleaner environment. If that works, you can start re-enabling your startup programs until you determine what’s conflicting with Scrivener and preventing the launch. Once you know the program, you may be able to adjust its settings so it does not conflict, or maybe just avoid launching it until after Scrivener has started if it’s only interfering with the startup. Usual suspects here would be security programs, but I’ve seen a couple instances where an internet browser has caused a problem. I’d check into those first if you have any running.

I’d been having a conversation with someone in support – I guess it’s marked as a private conversation? (I’d searched the forums and didn’t find anyone having a similar problem, so I figured it was just me, although I did find a mention in a topic that turning off the “Open recent project on launch” option was a good idea when one is having erratic launch.)

I agree with your hunch that a recent Windows update might have borked something – I’ve been running Scriv alongside GoogleDocs in FireFox for literally years with no problem (I use Scriv as an idea capture tool/outliner as I write roughs in GD.)

I will say that Scriv seems to START to launch-- it opens a completely blank window titled “New Project” – but then becomes non-responsive after a period of time (seems to be 15-120 seconds). If I CtrlAltDel to Task Manager, Scrivener isn’t listed as an application, but is listed on the Processes tab.

I did try that compatibility thing you mention, iirc, and oddly enough it offered to run in Win XP mode; this seemed so not right that I simply backed out and didn’t make a choice.

There should be a menu with a host of options for what compatibility mode to choose; XP might be the default if you’re already running Windows 7 anyway (since normally it would make sense that you’re setting compatibility mode because trying to run an older XP-only program). You should though be able to change this once you’ve ticked the option to run in compatibility mode at all. Trying it for XP wouldn’t hurt anything, though, if the Windows 7 compatibility setting doesn’t help; at least you’d see if it worked in XP-mode. And at least with my settings (which I think are the default Windows 7 theme) it doesn’t look that drastically different from running native Win7–the disclosure triangles become + and - boxes and the drop-down menus use the older divided XP style, but for the most part it’s the same feel.

For now at least I’ve found a restore point for the Scrivener.exe from last July – which works very nicely and seems to be letting me open my projects. As an added precaution I’ve turned off the options to check for updates, and to open whatever was open on exit. I’ve also done a “Save As” on the project - probably not needed, but I don’t suppose it’ll hurt.

Your reply convinced me to go back into the compatibilty and set it to Win7 ( no compatibility was selected previously).

It was the same on my system, that Scrivener did not launch any more, shortly after I had a Windows Update. (I run a Windows 7.) Multiple Re-Installation of Scrivener did not solve the problem.

But, after reading this thread, activating the compatibility mode in the scrivener.exe and setting it to “Windows 7” solved the problem at once and Scrivener is working fine again.

So, this information might be useful for other users who have or will have the same problem after a recent Windows 7 Update.