Roman Numerals for Auto Page Numbering Does Not Work in Footer

I cannot get roman numerals to appear in either my front matter or the main body when compiling.

I duplicated the Manuscript (Times) format saving into My Formats section. I assigned the part number section layout to my section type.

I edited the section footer trying both the <$r> and the <$p-r> tags. When I compile, this does not convert to a roman numeral, but rather continues to be an arabic number.

Why is this not working?

If I read you correctly, it sounds like you may be putting this placeholder in the wrong place. They aren’t a function of section layouts (which determine how content is printed and formatted within the page, one might have multiple section layouts working on a single page, so it wouldn’t work well to establish overall page settings from here), but of Page Settings. Specifically, once in that pane, click the “Header and Footer Text” tab, where you’ll be looking to insert page number placeholders and other text, like author name or book title.

You’ll note you can set up different running headers and footers for different types of content. I’m guessing you probably want the Roman numerals in the front matter or First Pages type of content, rather than for the entire book, but you can take a look at how Main Body is set up to see an example.

Thanks for replying Amber,

I am in the section you mentioned because I can get page numbers to appear and disappear based on changes. I just cannot get them to convert to Roman numerals. I tried both the <$r> and the <$p-r> and neither one works.

Sorry, I’ll need a little more detail on what it is you are trying, in that case. Walk us through steps you are taking, from start to finish.

When I compile my document, arabic page numbers appear at the bottom of all pages when in the front matter or main body.

From the Compile screen, I click on a format I duplicated from the Manuscript (Times) built in format so that I could edit it.

Because I need to change the footer for the front matter, I click on the pencil icon in the Chapter section layout. It is assigned to the section type “Chapter Opening” I defined under the Project Settings option earlier.

I see that the Chapter section is assigned to my defined Chapter Opening section. I click on the Edit “Chapter” Layout button. In the left navigation, I click on the Page settings. I then click on the header and footer text.

I click on the Front Matter in the left column. Under the footer for Front Matter is shows <$p>. I change that to <$r>.

I click on the Save button.

I then am returned to the compile screen.

I confirm that the front matter pages are assigned to the Chapter Opening section layout type.

I compile the document to a Word (.docx) format.

I open up the document and the page numbers are not lower case Roman numerals, but rather Arabic numbers.

I tried both <$r> and <$p-r> and neither of them works.

Okay, just to confirm only <$p-r> will work for page numbering. The <$r> is a general numbering token that can be used in the main text (Part II, Part IV, etc.), although lowercase in this instance.

I see that the Chapter section is assigned to my defined Chapter Opening section. I click on the Edit “Chapter” Layout button. In the left navigation, I click on the Page settings. I then click on the header and footer text.

I see what you mean, well to make sure it’s clear, there is only one “Page Settings” for the whole format, this isn’t tied to any particular Section Layout, so it doesn’t matter which one you select before visiting this panel, or how you get there.

Your Page Settings setup sounds good to me. The Manuscript (Times) doesn’t have <$p> in the footer by default, so I’m not sure how that got there, maybe you added that before to test it?

Here’s what I would do, instead of trying to get this page numbering thing to work, try something very obvious as a pure test. For the “First Pages” header and footer, type in “@@@” into each of the fields, and compile with that.

What this will test is to make sure your front matter settings are in fact working, that your document does have two different sections within it. If you are only getting one section (regular page numbering still), then try this:

  1. Go back into your binder and locate the front matter items. Are they just at the top of the Draft folder? If so, select them all, and use the Documents ▸ New Folder from Selection menu command. Name this “Front Matter”, and drag it out of the Draft, anywhere else is fine.
  2. Go back into the compile overview, and on the right-hand side, in the Contents list, tick the Add front matter if necessary, and select this folder you just created.
  3. The items in this folder should be added to the very top of the contents list, and they should still have your layout assignment.

So if that’s what the problem was: this is how Scrivener knows what is and isn’t front matter (or back matter). They have to be in separate sections, and designated using these tools. It’s not Section Types / Layouts that drive this higher level structural document decision.

I have a front matter folder set up and correctly defined. I assigned “@@@” into each of the footer fields in the page setup. When I compiled, all of the front matter compiled with “@@@” at the bottom and then when it entered the main body, starting Arabic page numbers. I then went back in and changed the footers to be <$p>, <$r> and <$p-r> in each of the fields and compiled again. This time, the footer for the front matter was 1 <$r> 1, 2 <$r> 2, etc through the six pages of front matter before starting the page numbering for the main body.

What program are you using to open the compiled DOCX? I gave this a try and found that although the lower- and uppercase Roman numeral page numbers appear correctly when the file is opened in Word (2016 for Windows), they load as Arabic numerals when opened in Nisus Writer Pro or Pages.

You might be able to get different results by switching the converter used to create the DOCX file. If you have Java installed (I currently don’t, so I can’t test this at the moment), when you open Scrivener ▸ Preferences and switch to the Sharing pane, you’ll see an option to Use Java converters for .docx under the Conversion options. This can take a little longer than Scrivener’s native converters, but it might produce better results for your current project.

EDIT: Whoops, I mixed up threads and had it in my head this was all working with the Mac version of Scrivener and using DOCX specifically. But since I can’t replicate the problem with PDF, maybe that second part at least is relevant. The Java settings don’t apply if this is on Windows (nor, I suppose, would you be likely to be trying to open the file in Apple’s Pages!), although there are is a similar setting on Windows to switch converters, if you have Microsoft Office installed. On Windows, I see the same problem with the Roman numerals appearing as Arabic when the DOCX is opened in OpenOffice Writer; however, switching the converters didn’t help. In that case, the simplest solution is probably to just set the pagination style for the section in the word processor after compiling.

I am opening it up in Pages. That is interesting to know Pages is reinterpreting the page number scheme. I will try creating this in a PDF format and see what happens. Thank you for the check.

Tested this opening in Word and the <$p-r> worked correctly. You caught the issue. Thank you for your help.