Room for another card in corkboard layout

If I set the corkboard to Auto, then Scrivener fits in four cards across…


…when really there’s room for five - this is what happens when the Cards Across setting is changed.


Is there any chance you’ll be tightening this up so Scriv uses all the space on the screen?

I’m not sure what else it could do here, it just looks at the total width a card takes, and if that is smaller than the amount of free space in the editor window it wraps to the next line—but if you want it to adjust the width of the cards so that it always fits the editor, then you can already do that by setting cards-across to something other than “Auto”. Try setting it to 5. Or changing the width of your editor by a few pixels.

You’re going to have this problem no matter how close we shave the definition of “index card” around the card and its shadow. There is always going to be a point where there are frustratingly 5 pixels holding back a line. Changing the metrics of the situation is the only way around that.

IMHO, the pictures clearly show that there is in fact enough room to display another card. When the ‘cards across’ setting is 5, the program finds enough room, and when the setting is changed to ‘auto’, it calcalates that there is not enough. So it looks as if the program is adding some more space for some reason.

This is on the list, actually; it’s including the space for the scrollbar in the calculation even when the scrollbar isn’t visible.

Great, thanks Jennifer.

But that’s a good thing to do, isn’t it? Otherwise the user’s exquisitely spaced n-across layout becomes an annoyingly inefficient n-minus-one whenever she clicks to a horizontal split. Or adds a card, or moves from parent to parent in corkboard view.

This is just for the auto-fit calculations, so it’s not really “exquisitely spaced” by the user–on the contrary, the user has expressly desired that the cards always fit the width of the given editor, keeping it flexible. If you set a specific number yourself, that is respected.

So the cards would be drawn a little smaller when the scrolling bar is up. A matter of taste, I guess. Thanks, MM.

In that case, you want to set the number of cards across and select “Size to fit editor”; then the size will be maleable while the number across remains set regardless of the editor width.

Slight change of topic, but the start-of-thread image shows what I’m looking for.
How can I change the index card to have only the pink line separating heading from text, and remove the blue lines?
Thanks

Select the Appearance tab in Tools > Options, then in the Color list choose Index Cards/Index Card Lines. Click the colour well to open the colour palette and change the Alpha channel to 0.

(There are plans to make this a bit simpler in a future version, but the Alpha channel trick works nicely to create invisible lines. :slight_smile:)