Running one text into another

If I have a Scrivener project with, say, five separate texts, when I compile the project each text appears as a separate paragraph. Is it possible to run one text into another in this instance?

So, for example, if I had the following two texts in my project:

and

When compiled they would appear as

Rather than with a linebreak after “ineluctably” and before “I am getting”?

Have you tried setting a custom separator to nothing in Compile settings ? What does that do ?

That’s the right idea, but this all by itself won’t work because the Custom setting inserts whatever you type into its own line with centre alignment formatting. Thus if you type in nothing, you just get a line.

However, what if you type something that will otherwise never occur and then search and replace to remove that and the newlines, replacing it with a simple space?


[size=80]Using an unusual Custom separator, like “^^”[/size]

If we have two lines of text in different files, then the compiled result will be something like the following:

I want to start my line here ^^ and end up here.

So now we have two carriage returns surrounding two carets to replace. We can type that into the Replacements compile option pane (insert carriage returns with Option-return). In the “With” field, you’ll probably want to put a single space so that you don’t have to remember to add one at the end of every document.

Compile, and we get:

I want to start my line here and end up here.

So, for items that you do want on a new paragraph, just remember to add an extra one in the main editor (or organise things so that you can use another Separator type, such as grouping files into folders, where folders would then become paragraph breaks).

Just remember you have that line in Replacements, because between the carriage returns and spaces, it will look empty. :slight_smile:

1 Like

What an elegant solution, AmberV. Thanks!

Alternatively you can mark the line a RegEx and type \n^^\n on the Replace field. At least it will be clear it’s not empty. :slight_smile: