russian language in scrivener

I am using Russian language in scrivener. Some parts of the words are underlined with red line. These words have correct spelling, but when I am trying to spell check system gives me sentence with the underlined part of the word (just few Russian letters) marked in red, and suggestion for this Russian letters in English. How can I fix it?

Hi,

It seems like you didn’t download Russian dictionary. Please, visit settings, choose ‘Правка’ section, then check for dictionary selected. Just after installation it should be ‘English’ dictionary selected there. If yes, press ‘Загрузить’, select ‘Russian’ dictionary and then restart Scrivener after dictionary download finish.

Hi,
Thank you, but I cannot do it. My “правка” button is second left in the top tool bar. So when I click on “правка” and bring pull down menu I do not see “dictionary” option. May be there is another way to download Russian dictionary. Or may be I am doing it wrong way. Please, help.
P.S. If you know Russian we could communicate in Russian.

(i’m not sure if PM on Russian was successfully sent)
I meant this settings dialog:


It is accessable from ‘Сервис -> Параметры’ menu. After you download russian dicrtionary you need to return to this page of ‘Параметры’ dialog, press ‘Выбрать…’ button and choose Russian dictionary.

Thank you very much. Now it works. I confused “правка” in the menu with the correct “правка” in “параметры” section.
Thanks again.