S3 binder clicks stopped opening documents in unlocked editor(s)

I no longer require a solution, as I reverted to an earlier copy of the document and manually copied in changed text, but I don’t know what went wrong so I’m reporting this as a bug.

I have a file imported from version 2, and have been editing it since the 21st without issues. Yesterday I began using a vertical split with the right editor locked in place.

Today, partway through editing, clicking in the binder stopped opening documents in the unlocked editor, as though it were locked (I’ve confirmed multiple times that it is not locked). Any clicked document highlights correctly with a blue bar in the binder; the document in the unlocked editor remains indented gray. Documents also do not load in the other editor if I unlock it and move the focus there.

I can open the document in the editor using Option-Command-O, it just no longer happens automatically on clicking. I can also open the file in the other editor (when it’s unlocked) by right-clicking and going to Open in other editor.

I’m not aware of having done anything unusual between when it was working and when it stopped. It may have occurred after I split a document using Command-K, but I’m not certain. When I reloaded an earlier version of the file and tried splitting a document with the same setup (left editor unlocked, right editor locked, scratchpad open) the problem did not replicate.

The problem does not occur in a different Scrivener file, or in versions of the file from this morning, but it is persistent with this file.

I tried:

  • Removing the split
  • Locking/unlocking both editors
  • Hiding and reshowing the binder
  • Turning collections on and off
  • Restarting Scrivener
  • Closing Scrivener and rebooting
  • Making a copy of the file from within Scrivener
  • Making a copy of the file in the Finder
  • Getting this morning’s version from Time Machine, and manually copying in the text of changed documents; this file works fine and it is what I’m now using

I will update this thread if the problem reproduces.

Have you checked that Navigate > Binder Affects is set to “Current Editor” (or Left Editor)? This may have gotten accidentally changed in a way that prevented binder clicks from affecting that editor split.

Ah, that appears to have been the problem. I set a keyboard shortcut yesterday via Mac OS to set bullet points to None, which worked yesterday and this morning, but sometime today the shortcut changed back within Scrivener to set Binder affects to None. I’m assuming that was the keyboard shortcut’s original function, and that some kind of automatic process caused it to revert at some point.

Thank you for helping me solve the mystery!

Thanks! I had the same problem and this was the same solution.

It was driving me crazy.