Save as creates a blank


Tried to save my text as a new file/new name the other day and it only created an empty file.
All the separate chapters and their names are there, but the words are completely gone. Word count is zero.

I’ve tested it several times and the result is always a blank.
Only way to back up has been either to compile it or go into the folder and copypaste the whole thing by hand.

I’m using Scrivener on Ubuntu 12.04

Try with the, maybe the bug is solved. :wink:

Nope, still creates a blank. :C


Edit: Oh darn, I should have mentioned this first, I’m using Scrivener through Wine.

I had this issue once…are you running it in any compatibility mode other than the default (XP)? Because strange and horrible things (like what you mentioned) happened to me when I used Scrivener with Windows 7 emulation.

I’m using wine 1.5.28 with the most recent version of windows scrivener, and I couldn’t reproduce the issue unless I was running as Windows 7.

ETA: I’m not sure if it matters, but I’m using a 32 bit WINE on a 64 bit system. (Games run better that way, especially Guild Wars 2.)

Looks like mine was set default on vista.

I’ll try the other settings for now, if that doesn’t help, update wine (currently 1.4) and see what happens. =)


Wine 1.4 set on Windows 2008 lets me Save As properly.

Thanks for your help. =)

I wonder if this board (Scrivener port on Linux) is really appropriate for Wine issues.
Maybe Winehq would be better?

I did not know it was a Wine compatibility issue when I brought it up.

Either way, the issue has been resolved.

Perfect, then!

There have been plenty of questions and such about WINE and Linux in here in the past. For the first several months of Scrivener, it was the only way to run it under Linux.

ETA: most of the people (Myself and a couple others) already handle the winehq page. We read here more frequently.