Save as template stuck at "Saving UI states"

Just upgraded to 3.0 this morning. Pulled up one of my existing templates that I created in Scrivener 2, made a few changes, then went to save as template and Scrivener gets stuck at “Saving UI states”. I’ve left it up for 20 minutes and it’s still at this spot in the save. I’ve even tried recreating the template using a blank 3.0 project and dragging/dropping all my files and folders into the new project - same result. The only way I can exit Scrivener is to Force Quit. How long should saving a template take?

MacBook on High Sierra 10.13.1

It would normally only take a few seconds, it’s definitely getting stuck on something. I would try the instructions in this knowledge base article to save the display settings, reset them, and then reapply them.

After doing that, try saving the template again.

Also, if you could share the project with us (either by zipping it up and attaching it to your reply here or by sending it to support for my attention), that would be great, as I’d love to find the cause.

Thanks and all the best,

Well, resetting display settings did not work. I have a lot of writing notes in my project outside of the manuscript - text files, PDFs, web archives and such. After fiddling around with my project, deleting and adding files here and there, I still cannot seem to find out what is causing the hangup. I’ll zip it up and send it to support to take a look. Thanks for your help!