Save bug in

Windows 8.

Bug sequence:

Edit file.
Save (ctrl-S)
Leave cursor on file in left hand pane and exit scrivener
Run scrivener - Scrivener opens last file which is now empty.

If I select the parent folder to text before exiting then when I come back in I am on selected folder and my edits are preserved.

Windows also seems to then have an issue with that file around permissions when I restore a backup of the original file before I edited it.

We could not reproduce your problem, minus10. We believe that it is connected with the access rights of your User Account. Scrivener is using a new approach when saving the RTF files, that reduces the probability of losing data due to crashes, but we might have missed something with the user rights. Do you run Scrivener as Administrator or as a Regular User? Can you try and run Scrivener with elevated Administrator user rights?

I’ll do that and get back to you.

I ran Scrivener as admin (was running under an admin account anyway) and behaviour was the same, though not entirely consistent.

I made one edit and let it auto save and it was fine. When I reopened it and added a couple more edit lines and let it auto save and close scriv , it was blanked again on reopening the project.

I run on an SSD if that changes matters? I’ll try the project on an HDD.

One more thing. My previous post could explain things if you have permission problems. If you have problems with the User Rights you should not be able to save any file. According to your post, your edits are saved if you move to the parent folder. Can you try saving via the menu File > Save and not via the shortcut Ctrl+S and exit Scrivener? Can you give us also more details about where do you leave the cursor, the mouse focus and do you exit Scrivener via shortcut or menu? I am afraid I cannot pinpoint what you mean by: “Leave cursor on file in left hand pane”. Do you have split editor pane(left/right) with the same file, or you refer to the Binder saying “left hand pane”? Many Thanks in advance!

Hi again,

Sorry, I should have been clearer, and I’ve done a few more experiments.

When I select the parent folder of the file in the binder which I have open on the left, I have no problem.

I can cause the problem without using Ctrl-S at all, and merely watching for the auto save on the file name (asterix) so the Ctrl-S seems to be a red herring.

Sequence is:

Go to file in a project with a parent folder under manuscript.
Add one line to end of file that already had text and wait for auto save.
Close Scrivener with text file still selected in binder on left.
Reopen. Most of the time, the file is fine.
Add another line and save.
Close and reopen, file is missing.
If I close Scrivener with parent folder selected in binder, seems to be fine.

I tried File->Save and same problem.

I have now also moved the project off the SSD onto a HDD and I can’t seem to get it to have the same problem. Speedy writes the issue? Going to leave it on the HDD for now :slight_smile:

SSD maybe a red herring as well. I run Acronis 2013 non stop backup on my documents folder but not on the HDD (which is a backup drive), and it just stopped working as I messed around more. It will be hooked in at low level to file writes to do it’s nonstop thing, so may be a bad interaction there.

Given this has reared its head since I updated to, how did the save change exactly and any chance of it being reverted?

Your feedback is very useful, minus10. I would not ever expect moving your project from SSD to HDD to make any difference. I use my SSD for work with Scrivener on every day bases and my HDD mostly for storage and never noticed any difference with the Scrivener Projects. It might be also the SSD driver or some SSD buffering, but as I said SSD or HDD should not make a difference in theory. So far the theory, one would say :slight_smile: . I am happy that moving to the HDD solves the problem, but I would like to dig the problem a little further with your assistance if possible.

  1. I believe your SSD drive has the active installation of Windows. Can you confirm this, please? Can you describe the way your SSDs and HDDs are partitioned.

  2. Can you open any command prompt(usually via Start > Run > type ‘cmd’ and press ‘Enter’). Inside the Command Prompt, please run one by one the following commands:
    echo %windir%
    echo %USERPROFILE%
    echo %TEMP%
    echo %TMP%

  3. What is the location of the Scrivener project when it saves properly and when it fails.

I would be happy to get back the result from the above points. Many Thanks!

  1. SSD is C: drive, 256GB and is Win 8 system disk, single partition
    Drive E: is 1TB HDD, single partition used mainly for backups and Steam

  2. Output from CMD:

Microsoft Windows [Version 6.2.9200]
© 2012 Microsoft Corporation. All rights reserved.
C:\WINDOWS\system32>echo %windir%
C:\WINDOWS\system32>echo %USERPROFILE%
C:\WINDOWS\system32>echo %TEMP%
C:\WINDOWS\system32>echo %TMP%

  1. Project is C:\Users\Paul\Documents\writing\novels{name of novel}

when I have issue, and E:\writing when I don’t.

Is your project rather large? How much RAM do you have? If you have a lot of RAM being used elsewhere, sometimes projects can look blank, since the documents aren’t all loaded in Scrivener all at once. (I believe it only loads into memory what you’re actually using.)

Also, I’ve noticed that on large projects, when I quit and it’s backing up, it won’t render the text in the editor. The text, though, is there when I open a project.

And are you running Steam at the same time as Scrivener? (I noticed you said the other drive is for Steam.) I’ve had issues with Scrivener and Steam running at the same time, although my issues could be caused by Steam and Scrivener running under different WINEPREFIXes. Steam always used to crash when I’d start Scrivener at the same time. (I was told this is a productivity “feature.” :wink: )

Everything seems perfectly fine with your setup and directories, minus10. I do not have good explanation why moving the project from SSD to HDD fixed the problem. Thanks for your feedback!

I have 8GB of RAM. The project is about 65k words with a few research references, so not big at all. The desktop monitor I have indicates plenty of spare RAM.

Ok, I think I’ve cracked it. If I disable Acronis 2013 Nonstop protection, the problem goes away on the original project. So the issue is not SSD/HDD, but rather I have Acronis monitor and backup all file changes in my docs directory, and that is causing the issue.

It seems therefore that the change to the way that saves are done has an unexpected side effect in conjunction with this software.

This can be an explanation. For some reason Acronis fails catching the file write operation (indeed file rename operation) when %TEMP% and Project Folder are on the same drive. I might install Acronis myself later on and optimize our saving strategy to work around this issue. Thanks for the feedback, minus10. It has been very valuable!

@minus10: Thanks to your report we improved the saving strategy in Scrivener. It still provides data protections, it should be also faster on some machines and you should not have any issues with the Acronis software, I believe. Can you please test v1.5.7.0 and let us know if it solved the problem, minus10? Thanks!