SAVE PDF TO SCRIVENER - not working with Big Sur OS

Every time I use “Preview” to open a PDF and want to save it to Scrivener by using the option SAVE PDF TO SCRIVENER in Preview, the document doesn’t show in Scrivener. My MacOS is the new Big Sur.
Is it just me or there’s a glitch with BigSur?

Hi flean,

I have tried this from PDF and from Safari and yes, its not going through.
Just to be clear. You are using the print feature right? File–> Print → Save PDF to Scrivener.
If so, then it looks like something Big Sur has done.

I suggest waiting for the new version of Scrivener (this week if all goes well) and see what happens.


It could be that in the update, the alias that points to Scrivener got damaged. This is a really basic technology actually, and you can make your own “buttons” to save PDFs to programs even if they don’t add an alias on their own.

Since the MAS version isn’t allowed to do it, we have instructions on how to set things up in the user manual, under §3.3.2, Installing Extras. Just follow those, only taking the additional step of deleting the one that currently exists, in the given location.

I haven’t tried it though, it’s always possible Apple broke the mechanism accidentally and nothing will work until they fix it.

I found some time to boot into the macOS 11 test drive, and have done some further testing on this. It looks like no amount of alias repair will solve this. Hopefully it is easy to fix, as I noted another program that has this particular facility in place (EagleFiler) does work.

I am having the same problem of not being able to use the print dialog to “print” a PDF into Scrivener.
Running under Big Sur. 11.0.1
Scrivener 3.2.1

Yeah, I just mentioned one post above yours that it’s confirmed.

Still not working as of mid-January, unfortunately.

Running Scrivener 3.2.2 for Mac, Apple store version, and Big Sur 11.1. Deleted the alias in the PDF Services folder and rebuilt it in both the user folder and the system-level equivalent – neither works. Both appear to print the file to .pdf but then it does not show up anywhere I can find in the current open project in Scrivener.

Hopefully a fix will make the next release - I know Big Sur is a challenge to keep up with, but this is great functionality I hope remains in Scrivener as it’s the easiest way to get error-proof research into a project while using separate MacOS workspaces for Scrivener and day-to-day action.

Why not just import the PDF directly to Scrivener after saving the print as a PDF?

That is indeed the straight-forward workaround. For one that does this quite a lot, the most efficient approach would be to save PDFs into a folder somewhere, and batch import them at the end of the day, and trash the folder contents. All in all, when batched like that, you’re only increasing the work you do by an ever so slight amount.

I advise AGAINST batch importing. I do this a lot for my research folder, and I have found that when I do batch importing, it will a lot of the times comepletely lock Scrivener up, forcing a “force quit” and a rebuild of the index. One at a time works best, from my experience.

That may be an issue in newer OS versions, or with the types of PDFs one is importing. I’ve never seen anything like that, but I’ve never extensively used anything past 10.14. Your mileage may vary, in other words.

The batch import issue (for me anyway) has been happening as far back as MacOS 10.12: Sierra and Scrivener 2 for Mac. Like what Amber says though, what happens to me though might not happen to others, but you should be aware that I’ve personally had these issues so that if you end up with the same issues, you know to back down to importing PDFs one at a time. :smiley:

It’s a little more time-consuming, but it works.

Still not working with Big Sur 11.1 and Scrivener 3.2.2 (non-MAS version). Would love to see this functionality restored, if possible.

The “Save PDF to Scrivener” feature on MacOS Big Sur, v11.2.3 is still not working. I am running Scrivener v3.2.2 (14632). This is a feature that I use frequently. Without it, Scrivener becomes a less viable tool for me. I have tried going to the ~/Library/PDF\ Services directory and deleting the ‘Save PDF to Scrivener’. I then restarted Scrivener and the file was recreated. However, this feature still does not work.

Is there a ticket tracking this issue in your bug reporting system? Are there plans for this to be addressed in the near future?

Thank you,
Chris Gennaula

I believe if you review the thread you are responding to, you will find it is on our list, and you will also encounter some workarounds that may work for you.

Thank you for your response. I am aware of the workaround of saving off the PDF and then importing it into Scrivener (and had done that before I even responded to this thread). This was the only workaround that I saw that worked. I did not see a fix for the actual problem. If I am mistaken, please point me to the solution that enables this feature to work again.

The second part of my question was “Are there plans for this to be addressed in the near future?” Is a fix planned for the next release or is this problem on a backlog of cases?


There is no fix for the underlying problem that you can make, Scrivener is not receiving PDF files via the mechanism of “opening” the PDF in Scrivener, which is how it worked before.

It is on the list to be fixed, I can’t really speculate much more beyond that into whether it can be or when.

What does that mean, saving a PDF to Scrivener? Where is it supposed to go if you do that?

It’s from the PDF drop down in the standard print dialog. It saves the PDF to the Research folder in the currently topmost open Scrivener project. If Scrivener isn’t open, then Scrivener is opened and the PDF is saved in the topmost open project as above. If no project is open you get an error message.

It used to be you could also drop a PDF right onto the Scrivener icon in the Dock, which makes sense given how this “Save PDF to Scrivener” mechanism works. All it is doing internally is saving a temporary PDF file and then loading it in the software that has an alias in this special folder. It’s not a special feature, but a convenience built into the system to avoid making a temporary PDF yourself.