Save Spacing and Ruler Tabs in Default Style?

I would like to change the default text settings, including SPACING and RULER . I have made multiple attempts, but I the only setting I can get to ‘stick’ is to change the fonts/sizes and the centimeter/inches display. I do this in the preferences/text-editing area. In order to change the ruler tabs, I have done the following:

  1. In a paragraph of text, I modify the ruler to the tab spaces that I want, I set the spacing as I want. Then, I go to ‘styles’, select ‘other’, click 'add to my favorites, type the name ‘Default’, check the ‘save font’ and ‘save ruler’ boxes, and save. I am always asked, ‘do you want to replace…’ and I click ‘yes.’ Then, as a test, I select a different paragraph of text, convert to default, and…the ruler tabs go back to their very odd original spacing which I think might be based on centimeters, but even that is strange, and the spacing goes back to the original.

soo…I try this:

  1. I set the paragraph as I want, as above. This time, I go in to preferences/text-editing, select ‘default’ and click ‘use current.’ Usually the spacing does not stick, nor the tabs. So then I reset the tabs and the spacing, I click ‘apply’ and I save my preferences. And then I test again. No luck.

I think that I was successful in doing this once, a long time ago (well, not that long, I have only been using Scrivener for a 6 months), but I think it was on a previous version. I am running the current version, or what I thought was the current version (1.1 beta).

I realize this is a rather small thing, but I am using Scrivener for my dissertation and there is enough reformatting that I need to do when I export into Word. I can’t figure out if I am doing something wrong, or if there is an error in the program (note: Console.app doesn’t register any problems…).

Any ideas?

UPDATE: I checked my version again, and decided to download 1.08. I though I had this, but maybe not. Once I reinstalled, the ruler changes seem to stick. The spacing still doesn’t, but it was the ruler that was making me really crazy. But I am not opposed to help with the spacing issue.

Many thanks,
Maria

Sorry, I thought I’d answered this, but missed it.

I’m not 100% clear of what the problem is - can’t you just use the “spacing” menu in the ruler in the Preferences? Or are you trying to achieve something different?

Best,
Keith

KB,

Thanks for catching this. When I refer to spacing, I mean the option to choose single space, or to add padding above or below the paragraph. I typically add some padding before a new paragraph. It is the drop down menu that says “spacing.” I don’t have a problem setting the spacing that I want, but I can’t SAVE it as default. So, every time I try to modify the default style, saving my changes, when I actually apply the default to other text areas, only the font (and now the ruler) takes effect. The spacing returns to the scrivener default of 1.0, no padding.

Does that make sense?

Maria

This sounds like an OS X thing - Scrivener uses the OS X text engine. Could you try doing this in TextEdit and see if it suffers the same problem? My suspicion is that it will. Unfortunately, whilst Scrivener benefits from the brilliance and ease of the OS X text system, it also suffers from any bugs or oddnesses in it, too…
Best,
Keith

I didn’t even know there was a “standard OS X style dialog” till I started using Scrivener, and I can see why, 'cause boy is it counterintuitive and awful. :slight_smile:

TextEdit allows you to set the preferred font and font size for new documents, separately for RTF and plain text docs. You’d think this would be the default style, but not quite.

As far as I can tell, TextEdit’s “Default” style command means:

  • Reset indents and tabs
  • Reset to default typeface
  • Clear any bold, italic, underline, outline or shadow

It doesn’t affect the font size, and even if you have, say, Semibold Italic defined as the default font for new documents in the prefs, “Default” still resets it to plain.

Scrivener’s behavior seems similar.

So, my question is, when I create a new project using the Novel Manuscript template, and Scrivener sets up the title page in single-spaced Courier 12 and the first scene of the first chapter in single-spaced Optima 13, where does that come from? The template? If I reformat it and save my own template, will I get my own formats the next time? Or is it hard-coded? (The actual ordinary text editing window seems to be the only place where the preferences don’t allow you to set a font.)

And is this something I should shut up about till after going through the tutorial I wasn’t planning to go through? Sorry, I’ve got 70,000 words in MS Word already, and was hoping to hit the ground running, and while I’m totally behind Scrivener’s “what you see may not be what you want” philosophy I’m real picky about what font I work in…

–D.

Well, certainly the tutorial and Help file would… help. :slight_smile:

Basically:

The Text Editing Preferences is what you want. I know you say you used this, but maybe you misunderstood. This sets the ruler and font formatting for all newly created documents (in any project). It does not affect the font or formatting of any documents you have already created. However, you can use Documents > Convert to convert current documents to have the style in the Preferences.

The style you set in the Preferences should be the style you are most comfortable using on screen. It doesn’t have to be how you want it printed out or in your final Word file. You set the formatting for the exported file in File > Export Draft. Thus, the file you output can have a different format to what you see on screen.

As for the Novel format template… The Optima is what I had set up in Preferences when I typed it. The Courier stuff I did manually. The reason for that is that the title (Courier) pages have “Preserve Formatting” set. This means that when Export Draft overrides font and ruler formatting (you can choose whether Export Draft should do that in the Formatting pane), the title pages will not have their formatting overridden. This is so that they can have different paragraph formatting to the rest of the text. However, because they will ignore the formatting, I change the font in those files to Courier so that they match the export format.

I am not sure if that answers your question because I’m still not 100% sure of the problem, I’m afraid.

All the best,
Keith

Sorry to resurrect an old post, but I am having a bit of a problem:

When I apply a style (default, user-created), all text formatting is wiped. This means that every book title in a citation is no longer italicized. And yes, this is a problem in TextEdit as well. Needless to say, this is a royal pain for citations!

Does anybody know of a way to create a style that DOES NOT remove font formatting? I have tried to do so a number of ways (such as not including the font in the style), but it still wipes all formatting.

Thanks,
Maria