Save+Undo Text Deletion [FIXED]

I wrote 1,010 words for NaNoWriMo last night, and came to write some more this morning. The indentation had disappeared (at that point I still had version 1.0), so I went to select all and attempt to get it back. The first time I pressed ctrl-a, it worked fine, but I accidentally clicked off it instead of right-clicking, so I did it again - and everything in that particular page disappeared. I tried pressing undo, but it wouldn’t come back.

I think I’ve managed to reproduce the issue - though sadly too late to save my writing - but I can’t do so reliably. What I think I did was forcibly save with ctrl-s and then press ctrl-z. (missing the A key like an idiot…) Pressing ctrl-y will bring it back if this happens. For some reason, although I did it several times a couple of minutes ago in the latest version, which I just downloaded, it now isn’t happening any more. If I manage to reproduce it again, I’ll post an extra comment to this post with further details.

If it’s helpful, I’m running XP Pro SP3 - if any more information would be useful, just ask!

Keep up the good work, I really like Scrivener (when it’s not doing horrible things to my NaNo project! :wink: )

Further to this post, just as I submitted I had another idea, so I tested it - I can now reproduce the bug reliably. It doesn’t appear to happen in the “Research” section, only in “Draft”. The sequence of steps is as follows:

  • Click onto the page you’re testing from another one (it won’t work if you’ve already been writing on it and haven’t moved the view away since)
  • Click into the text, anywhere
  • Press Ctrl-S
    (- Wait as long as you like - it doesn’t seem to be time-dependent.)
  • Press Ctrl-Z - your text should disappear.
    (- Press Ctrl-Y to retrieve your NaNoWriMo project!)

You can then continue to type as normal after retrieving your text with Ctrl-Y, but pressing undo too often will take you back to where you were after saving and then delete everything. It’s as if force saving under these circumstances causes all of the text to be registered as having just being entered.

I can no longer reproduce this issue with Beta 1.3, so I guess it’s fixed!

Thanks for the hard work and awesome program! :smiley: