Sb2: Text centered in Scriv does not export as such

Hi Keith. I’ve centered some text (my chapter headings and scene breaks) in Scrivener, but that formatting does not seem to survive an export. I’ve looked at the exported drafts in both TextEdit and MS Word. The centered text looks great in Scrivener, but is left-aligned in TE and Word.

Another thing that may or may not be related: I choose to have no first-line indent in my Scrivener documents, but when I export, the first line is always indented 4/10ths of an inch (in both TE and Word). Of course, I can fix this globally in TE or Word, but I can’t figure out why the setting in Scrivener is overridden on export and the default of 4/10ths is used instead.

12" PB G4
OS 10.4.7
Word X and TextEdit 1.4


I found the Project Settings and was able to get rid of the first line indent issue–hooray! But now I’m confused–can I ONLY select one option for the exported alignment–all left aligned, centered, or right, etc.? IOW, will I have to search for each chapter title and scene break in the exported draft to center it manually? (Please say no, please say no…)


Yes, the Export settings will override all formatting. It is there for those who want basic export formatting without having to worry about formatting their individual files.

If you would like extra control over the formatting of your exported document, delect the “Use Export Settings” check button in the Export Draft sheet. If that is unchecked, the format of your individual documents will be used. That way, you can format how you want.


Wonderful! :smiley: So this was no bug at all–thank you, Keith.

One suggestion (though it’s entirely possible that I missed this explanation of this setting in the tutorial, and if so, my bad!). Could you reword this setting for clarity? Perhaps something like (only better :laughing: ): “Allow Export Settings tab (in Project Settings) to override Scrivener formatting”? Just a thought, I hope it helps. Thanks!