sb3 - Capitalization

Not sure if this is a bug or a feature request, but Scrivener is a bit agressive with the auto captialization. For example typing U.S. will capitalization the next word and typing e.g. capitalizes the G.

Actually, this has only just cropped up this week: … 3&start=15

I have fixed this somewhat for beta 4 - auto-caps will never rival that of Word or anything, but it should at least be a little better in some of these situations. From beta 4, e.g. will work fine. However, any word following something like “e.g.” or “U.S.” will still get auto-capped. It is a very basic, lightweight implementaiton that just capitalises any word that follows sentence-ending punctuation (.?!..) after a space. Word is a dedicated WP, and no doubt it holds a large dictionary of words that end with a period that should not cause an auto-cap, and has many other complicated algorithms - and like I say, Scrivener is not trying to rival that. If you do find auto-caps more distracting than helpful, you can turn them off via the Preferences.

All the best,

An autocap algorithm that can’t distinguish between abbreviations and sentence terminaters is just annoying. Less being more, why not do away with autocaps altogether? At the very least, the default autocap setting should be “off.”

PS: beta 3 is a beautiful thing. Thank you Keith, and thanks to your devoted contributers and beta testers.

If you don’t like it, you don’t have to use it.