Scapple hangs during Auto-Save (Window 10)

I own both LL products and I love them, but Scapple hangs every time it auto-saves. This wouldn’t be a big deal if it didn’t auto-save -every- time you make a change. So most of the time when using it I have to wait 5 seconds or so between each action.

Is there a way to fix this? There is no option to disable the auto-save or change its frequency. I tried several personal ideas, but nothing seems to help (Run as Admin, moving the file to a different location etc).

I really love Scapple. As a visual person, it really helps me. However, this feature makes it hard for me to work with.

I’m running the latest version of Windows 10 with 16gigs of ram, 4ghz i7, on a SSD.

The auto-save interval is adjustable.

Tools, Options:

However, if Scrivener is hanging every time you save, something is interfering with your disk access. Do you have any third-party software like anti-virus/Internet security software that is performing real-time scans of your disk?

I believe that setting is in Scrivener, I’m asking for Scapple. ^^

I would love to have that setting in Scapple.

So you did. Apologies. I don’t know of a way to set that in Scapple, but I confess I don’t use Scapple that much.

No worries. ^^

Yeah, hopefully they will update Scapple someday… I don’t know how different the Mac version is to the Windows one as they have different version numbers. This is likely just a Windows thing, or it could just be me.

I have noticed that the Scapple file size plays a part in the auto-save speed. If I use large image files it takes several seconds to save. So lately I try to make sure I use images that are 200k or so. I reduced one Scapple file from 30MB to 8MB, which did help, but it still hangs to auto-save, just not as bad.

I never notice this issue in Scrivener, so I assume it might just be that they need to update Scapple for Win10 or something.