Scene spacing in Final Draft

When I compile a screenplay, the scenes show up in the compiled FD8 screenplay with varying numbers of spaces between them. Sometimes the spacing is correct, but between other scenes there may be as many as 7 line spaces. I’ve been all through the Compile options and the Scrivener preferences (I know from searching the forum people have been told to set the scene separator to one line, and I think I did that once, but danged if I can now find either that instruction on the forum or the place in the Scrivener controls where I can set that.)

How can I consistently achieve correct spacing between scenes in FD?

Thanks so much.


Have you double-checked that there is no extra spacing at the end of your scenes inside the text documents in Scrivener?

Also, check that you haven’t got any page padding turned on in the “Formatting” pane of Compile (although that should only affect anything starting on a new page, and not inter-scene spacing).

All the best,

The Level Settings button in the Formatting pane might be hiding some spacing as well in the form of stray carriage returns in either the prefix or suffix field. As you click through rows in the type selection table, keep an eye on the preview window and watch for any blocks of text that suddenly jump down a line or two.

Many thanks for your responses.

I’m finding this quite strange. Trying to follow your suggestions, I searched all over the User Guide and tutorial for where to find the formatting pane, because it wasn’t showing up. Took ages, but eventually I found it. Turns out the full list of Compilation Options only shows up if I set ‘format as’ to ‘original’. If I set it to ‘Custom’ or ‘Screenplay’ most of the options disappear, leaving me with only the following to play with:

Script Settings
Page Settings.

And even in Original, once I select ‘Compile for final Draft 8’, all the options disappear again, leaving me only with the above list once more.
Is this normal?

Anyway, page padding is definitely set to zero.

I think the issue is with the spacing at the end of my scenes, as you suggested. And (yippee!) I can sort that. But I seem to have opened a can of worms here and had better try to understand where I"m going wrong with the formatting pane before I try to go any further!

Amber, I am so sorry, I haven’t a clue how to do what you suggest. How do I ‘click through rows in the type selection table’? All I get is the greyed-out Latin.

Thank you very much for your patience.

Yes, this is absolutely normal! The compile settings will only show the options that are appropriate for the format to which you are exporting. When you export for Final Draft 8 FDX format, a number of the compile options just don’t apply to that format, so they are hidden out of your way seeing as they have no use.

I apologise, because in this we have given you some confused and bad advice - the “Formatting” pane is indeed hidden when you export to FDX format, because it is not used for that format, so page padding and suchlike would not apply - I had forgotten that, sorry.

I’m glad you found the problem, anyway!

All the best,

Many thanks, Keith! (Not feeling quite so stupid now…)