Scenes as chapters in compile

Hi everyone,

I’m going to try and make this as clear as possible. Any specific keyboard commands you may have for resolving this issue would be much appreciated, as I’m totally blind. I use the menus in Scrivener commands rather than say “right click”. Now that I have that disclaimer out of the way, I’ll ask my question. Scrivener is amazing with VoiceOver the screen reader on the Mac, and I plan to record a tutorial for anyone who may be blind/visually impaired who’d like to use it.

My problem is I created folders for my chapters, and then titled my scenes inside those folders the same as my chapters. So for example chatper 2 Unraveling and the accompanying scene inside this folder have the same name. This is fine until I get to the compile stage. I want a page break before and after each chapter, and each scene to be classified as a chapter rather than a scene. Is there any way to accomplish this on compile? I’ve already tried assigned section layouts and changing the structure there. But it doesn’t seem to work. Can I just write text in the chapter folder, or is that not an option? All i want is for my scenes to show up as chapters. Thank you for any help you can provide.

It is possible to write text in folder documents, and one way to resolve the problem would be to use the Documents → Merge command to simply combine the “Chapter” and “scene” documents.

Another alternative would be to simply exclude the “Chapter” folders from the Compile output altogether.

And the final alternative would be to use a Section Layout for the Chapter folders that only includes the title, and a Section Layout for the scenes that only includes the text. This is how many of the Compile Formats supplied with Scrivener are designed to work.

Katherine

Hi Katherine,

Thank you for your concise and thoughtful reply. I will try what you suggested. If I just uncheck the box next to chapters, will that exclude them from compile? Or do I need to do that in the binder itself before compiling?

Yes, unchecking the Include in Compile box should be all you need to do.

Katherine

Hi Katherine,

Thanks again for all your help. Where would I find that “include in compile” box?

There are two. I apologize if my instructions aren’t screen reader-friendly. Please don’t hesitate to ask me to clarify if necessary.

First, “Include in Compile” is one of the boxes in the third “Metadata” tab of the Inspector pane. This setting can also be accessed in Outline mode, via the View → Outliner Options → Include in Compile item.

Alternatively, the Compile command offers a list of included files. The main Compile screen has three panes: Formats, Section Layouts, and settings. The settings pane has several tabs, depending on the output format, but the first of these lets you “choose which documents should be compiled.” (More commonly known as the Contents tab.)

The Contents tab, in turn, has three columns: an unlabeled one, then Title and Section Type columns. The unlabeled column contains checkboxes: check/uncheck a document to include/exclude it from the output.

Katherine

I think the most efficient way to toggle the “Include in Compile” setting, using VoiceOver, is to use the button attached to the editor view. To get there:

  1. Use Control Option Command Down Arrow, to move the selector into the footer bar.
  2. Hit Tab twice to select the Include in Compile button, and Spacebar to toggle it (you may need to use Control Option Space).
  3. To get back into the editor, use Shift Tab three times.

Hi Amber,

Thank you for the helpful info. I have tried your suggestion and when I hit control, option down arrow nothing happens. DO I need to be at a specific point in the text document to make this occur? If I toggle the metadata settings in the inspector, I can see the “include in compile?” dialog box that comes up. BUt again, just wondering with your suggestion if there’s an easier way to get there. Thanks again for all your help.

It is the shortcut that you would use to move within sections of the user interface, which for me is three modifiers: control, option and command, combined with the arrow keys. The element where this button is, is below the text editor so down arrow should move down to that zone. You’ll know you’re in the right place if you get ‘change text scale’ control, and that is where you would hit Tab twice.

Hi again Amber and Katherine,

Thank you both for your help. Katherine, your instructions are screen reader friendly. Amber, I will definitely try what you suggested using the three modifier keys with VoiceOver again. Maybe it didn’t work because I was in the text box where you write.