scratch pad bug and other issues

I gave a go to v.1.2.1 and indeed there is a speed gain.

  1. I found this bug: I made a note in scratch pad with only a screenshot (a small one). When I try to drag and drop the captured image to the main scrivener window everything quits with no warning or message.

  2. I confirm that in a clean winxp one needs to install Visual c++ 2008 to launch the program. I have now tried to install c++ 2010. I do not know if there is a proper version to install, and v. 2010 causes the above issue.

  3. There is no icon of mathtype to put on the toolbar. I installed mathtype after installing scrivener. In your tutorial video (for mac actually) there is instead this option.

Thanks.

I believe it’s the 2008 one you need to install. (At least it was for me with WINE.) I’ve found that later isn’t always better for some things.

Thanks for the feedback.
It would be not a bad idea if the original scrivener installer comes with the proper c++ libraries. They can be put in the same folder of the application, which gives (in the win world) priority to the possible presence of other libraries in the system.

Other small addition to the new (appreciated) feature of mathtype compatibility. The images look really of very low quality. See image attached:
scrivener-mathtype.png.

Is this normal?
Thanks

I think the library installer is already distributed with the software. Check in the …\resources sub-folder.

Quality issue on equations: are you zooming the text editor? Graphics zoom with font size, so if you’ve got the editor zoomed to 135% or something then it will not appear as crisp as the file actually is. View at 100% to see its actual quality.

@AmberV thanks.
You are right on zooming. In fact I realized that it was over 100%. With normal size, as you say, it looks better. That seems however strange, since I belive that mathtype equations are vector images. Probably thre is a problem of rendering.
Any workaround for the icon on the toolbar?

In that case it is very strange that the application does not run in a clean winxp sp2-3 OS, while it runs after installing the libraries.

The problem is that the Scrivener editor does not embed vector graphics (does RTF even allow it, outside of MS OLE stuff? I’m not sure about that).

I’m not sure what this is in reference to.

I might have phrased that poorly. The installer is provided, not the library as a linked system that Scrivener can utilise out of the box. The installer was initially chained into the main application installer so that all of this happened automatically—but that unfortunately caused other widespread problems during the beta, so it was removed and is now something you need to run separately if necessary.

I do agree it is a bit frustrating. I’m not sure how flexible the installer system is, but a stage that tried to detect the C++ library version level and asking the user if they wished to install the 2008 libraries would be nice. A lot of these things are black boxes with config files though.

I was refering to the option (present on the mac) to customize the toolbar, by putting a Mathtype Icon, a feature probably missing in the Win version.
Thanks

Ah, I see—I’ve added it to the list.

No then, only Alt-e,i,m.

Update on v. 1.2.3.
On reference of bug n. 1 at the opening message of this post, there is even a more basic way to reproduce the crash.
a. paste an image from the clipboard to scratch pad (no text added, apart the title): the image could be even this simple smile: :wink:
b. select the image in the stratch pad and either with the right click or with the keys crtl-C, try to copy the image back to your clipboard.
c. the whole scrivener crashes with no warning whatsoever.