Scratch Pad Issue

I just discovered the scratch pad and tried it… and couldn’t use it!

I’ve looked to see if this was posted by anyone else and could not, so wanted to post.

I’m running:

Version 1.2.3 Windows
Dell XPS 502L
Windows 7 Home Premium 64-bit
Core i5
6GB RAM

The issue:

I open the scratch pad with Ctrl-Shift / OR via the Tools Menu.

I click in notes area to type text.

When I start typing, Scrivener vanishes, no error messages or anything. I have to restart Scrivener.

I’ve checked to see if this was related to a particular key… but any keystroke will produce this behavior.

Is this a known bug or have I found a new one?

Many thanks, everyone.

RW

I haven’t heard of anything like that before, so it sounds like a new bug to me! So I take it both the scratch pad window and any & all project windows open in the background are closed too? Do you not get any crash alert messages? Even if there is no alert, Scrivener may still have generated a crash report. Check in the main software folder for a subdirectory named ‘minidump’, if you see anything in there, please send a copy with a link to this thread to windows.support AT literatureandlatte DOT com.

Sorry about the slow response, I don’t have internet at home at the moment, so my online time is pretty scattered about the yard :smiley:.

To answer your question(s), there was absolutely no warnings about the crash. I pressed a key and in less than a second was looking at my desktop. Everything went poof.

I checked the minidump directory, and I see 3 crash reports - I’ll send them in.

Cheers!

RW

Thanks, that might be helpful. Even if it just dumps to the desktop it might still get a chance to report why. Some crashes are so swift that can’t be done.

Amber, I’m am on Windows 7 pro, using Scrivener 1.2.3.0 and have the exact same issue.
Apart from this issue, this latest release is just wonderful. Thank you.

Minidump file attached. Thanks.

I think the attachment didn’t come through, unless you mean you sent it to the support e-mail address. :slight_smile:

Arhhh, sorry about that.
I’ve tried again here and just noticed this error message when I attempt to upload the file: “The extension dmp is not allowed”.

Is there a work around for this or do I need to send it to the support email address?

EDIT: minidump file sent via email. :slight_smile:

Thanks, that’s probably for the better anyway. Future reference, if the forum doesn’t like your attachment, make it a .zip file and try again. :slight_smile:

Hopefully the crash logs will tell Lee something useful about this, but in the meantime I’ll suggest a few for clearing the problem. I notice at least one of you still has the Ctrl+Shift+/ shortcut listed for the Scratch Pad, which means that your shortcuts weren’t updated with the latest release: the new shortcut is Ctrl-Alt-Shift-P, which allows for the scratch pad to be called up whenever Scrivener is running, even if the program isn’t in focus (this wasn’t possible with the \ character, thus the need to change it). Resetting the keyboard shortcuts to correct that might be enough to also kick out whatever gremlin is causing the crash. Note though that you will lose any custom shortcuts you’ve assigned, so you’ll need to redo those.

To reset the shortcuts the simple way, go to the Keyboard tab in Tools > Options…, click the “Import” arrow and choose “Scrivener.” Though it’s usually not necessary, I’d also suggest restarting Scrivener (or even rebooting your computer) to fully clear this out.

That should get you the new shortcut for the Scratch Pad, so try it out and see if you can create and type in a note without the crash.

If you’re still crashing, you can go a step further and use the “Defaults” button in Tools > Options… to reset everything. You can click the “Manage…” button first and choose to save your current settings; it’s possible that you’ll be able to reload them later without it triggering the crash bug. After you’ve saved, click “Defaults”, close and restart Scrivener, and try the Scratch Pad again. If it works without crashing, try loading your saved preferences.

If you’re still crashing after using the “Defaults” button, resetting the registry manually is the last thing to try; this is a bit more complicated and will again wipe all your preference settings from the Options pane, but it’s been effective in fixing this crash issue for myself and a few other users who had this during the public beta testing. (Incidentally, did both of you at some point have one of the 1.1 beta versions installed? I’m only aware of this being an issue for users who did, and probably it was a specific one of those that caused the bug for certain configurations, as the crash report was quite rare.) Save your preference settings if you didn’t already, since again you may be able to reload them afterward without triggering the bug, then:

  1. Make sure Scrivener is closed.

  2. Type “RegEdit” in the Windows start bar search field and hit Enter to run regedit.exe.

  3. This should open the “Registry Editor”. In the tree view in the left panel, navigate to “HKEY_CURRENT_USER\Software\Scrivener\Scrivener\Options”.

  4. Right-click on the “Options” item and choose “Delete”. Be careful to only delete this Options key.

  5. Close the Registry Editor.

When you restart Scrivener, all the preferences in Tools > Options… will be back to their factory defaults, so you can try loading the saved preferences once you’ve confirmed the Scratch Pad is working. (If it’s still crashing, you might as well reload them anyway, of course.) If loading them causes the crash again, you’ll need to redo them manually. After which, you should save them again as a “clean” version in case you ever need to reload again!

Thanks much. I opted for the path of least resistance and just “re-defaulted” everything. The problem has disappeared.

I did use the 1.1 beta at one point, so I imagine your suspicions about that are spot on… and then the keyboard definitions didn’t update properly at some point either.

I’m good to go - thanks again!

RW

Sorry, just so I’m clear on this, you fixed the issue by going to Tools > Options… and clicking the “Defaults” button?

I’m glad things are sorted for you now! Thanks for the update.

Just to let you guys know that (for me) attempting to write in scratchpad still crashes Scrivener in the new 1.2.5.0 version.

Did you try resetting the options to defaults as described above and restarting? Did you upgrade via “Check for Updates” or did you uninstall your previous version and do a fresh install of 1.2.5? If the former, try uninstalling and reinstalling 1.2.5 in addition to clearing the options.

If you’re still getting the crash, please navigate in Windows Explorer to the Scrivener installation directory (e.g. C:\Program Files (x86)\Scrivener) and open the minidump directory there, then right-click the most recent .dmp file inside and choose “Send to \ Compressed (zipped) folder” and attach that in an email to windows.support AT literatureandlatte DOT com with the description of your crash. Let us know too what version of Windows you’re using and whether it’s 32- or 64-bit.