Scratchpad misbehaving

I first emptied my notes from the scratchpad folder; the only file left was “Untitled Note”.
Then I wanted to use scratchpad, so I copy pasted in the bottom window, selected the “Untitled Note” title, changed it & clicked “+”.
An “Untitled Note-1” appeared with my pasted document, “Untitled Note” became empty, my title disappeared…
O-kay… so I did it again:

  • select the “Untitled Note-1”, change the title, click “+”
    —> I now have an “Untitled Note-2” (with my document), an “Untitled Note-1” (empty), and an “Untitled Note” (empty)…
    …So I did it again, & the same repeated with a +1 increment, etc…

I deleted the whole stack of notes except “Untitled Note”, and tried again, not to avail.
I tried to introduce a non empty .rtfd file via textedit & the finder - that did not produce better results; strangely, I could not edit the title of this note!

I remember that when I first tried Scrivener, the same (or similar) happened, and it was a few weeks before I tried scratchpad again… when I did it worked.

====>> The same happened today, I did other things on the computer for some time, and when I went back to scratchpad, it had resumed normal ops. [so it works well now!]

I don’t know if this has happened to someone else, or if hit a wrong sequence at some moment, but I could not find a similar report in the boards.

Take a look at the note in the scratch pad folder in the Finder - check you have permissions to edit it. I’m wondering if the permissions have got messed up on it somehow.

All the best,
Keith

Yes thanks KB - the permissions are fine, but maybe that is what happened?

One more of what I think is a “misbehavior”:

1- I create a note by pasting content in the “untitled Note”
2- then I edit the title from “untitled Note” to “my title”
3- if I click on “+”, an “untitled Note” appears, “my title” note locates itself in the list alphabetically.
However,
4- the pasted text is in “untitled Note” and “my note” is empty.

Unless,

  • instead of 3-, I first click on another random note in the stack, then click “+”; in which case the “untitled Note” newly created is empty, and “my note” contains the document I just pasted.

Has anyone else encountered this?