Screenplay screen-numbering & accurate page count

I love this application but as a screenwriter it has two significant problems:

  1. there appears to be no way to add scene numbering, even in Compile.
  2. the pagination is more padded than either Final Draft or Screenwriter.

And I will add, because I’m here now:

  1. the Final Draft export creates a default landscape orientation, which means when you adjust the page parameters in Final Draft, you definitely don’t have a clear relationship on page count between the Scrivener and the FD doc.
  2. the RTF export has loads of artefacts.

Many thanks.

You can do this - just use the auto-number tags. See the stage play templates for examples.

Pagination is never going to be identical across systems. Scrivener uses the standard OS X text system.

It doesn’t do this by default - I’ve never seen FD export create a landscape document, and no one else has ever reported this, so this must be something specific to your settings somewhere.

I don’t know what you mean by this - there are no know issues with the RTF export, so I’ll need more details.

All the best,
Keith

Thanks for getting back so quickly, Keith.

  1. auto-numbering: unless I’m wrong, this is an entirely manual entry. With scripts, one generally has to generate both unnumbered and numbered versions of the same text, for different scenarios, eg a script reader (no numbers) vs a production manager (numbers). So, Final Draft and Screenwriter have global on/off buttons which are linked to the Scene Heading lines, “on” gets the numbers, “off” …well.

  2. I take your point, but the padding is actually of a significant size - adding something like 5 pages per every one hundred over either Final Draft or Screenwriter, or an additional 4 lines or so per page. It may be that I can adjust this to an extent in the Compile, as I put your folders to great use; but Scrivener does add padding before each Scene Heading, which actually makes the text more legible (I much prefer it as a working document), but adds length that isn’t there in the manuscript and gives a misread as to the duration of the film. The more scene changes, the greater the discrepancy.

  3. I take your point.

  4. I should have been much clearer. This has to do with when the RTF is imported into Final Draft, for example. So the Scrivener-generated RTF file on its own looks okay, but to illustrate I give you the first two scenes of an example output:

Here’s how this example should read:

INT. GROCERS & DISTRIBUTION WAREHOUSE. MAIN STORAGE - DAY
Very busy, to’ing and fro’ing. A forklift drives in. Stacks of boxes everywhere - veg & fruit.

INT. GROCERS & DISTRIBUTION WAREHOUSE. NEON-LIT ROOM - DAY
MEN unpack marked crates of oranges, take out hidden brown-paper packages, unwrap them to produce plastic bags of white powder.

INT. GROCERS & DISTRIBUTION WAREHOUSE. ASSEMBLY ROOM - DAY

Here’s how it actually reads when imported into Final Draft:

INT. GROCERS & DISTRIBUTION WAREHOUSE. MAIN STORAGE - DAY
Very busy, to’ing and fro’ing. A forklift drives in. Stacks of boxes everywhere - veg & fruit. \pardINT. GROCERS & DISTRIBUTION WAREHOUSE. NEON-LIT ROOM - DAY
MEN unpack marked crates of oranges, take out hidden brown-paper packages, unwrap them to produce plastic bags of white powder.\pardINT. GROCERS & DISTRIBUTION WAREHOUSE. ASSEMBLY ROOM - DAY

…All those “\pard” phrases that are added where there should be carriage return. When I generate RTF files from Final Draft or Screenwriter and import them into their counterpart, I do not get this problem. I suspect it’s that extra bit of space Scrivener gives before its Scene Headings (as I said before), and I wonder if that is then imported as some form of undecoded redundancy. In turn, this means that Scene Headings are not recognised as such, and one has to go through the whole document and add formatting to elements.

Many thanks for looking at this,
Jonathan

We wouldn’t call it “Auto-Number” if it required manual entry. :slight_smile: Did you take a look at the stage play project templates like I suggested? You can enter auto-number tags using the submenu of the “Edit” menu, and a full list and explanation is available under Help > Placeholder Tags List… If you can’t insert the tag as part of a title, then you could just have it there in the text and remove it from the unnumbered version using Replacements during Compile.

Scrivener uses the same line spacing as Final Draft, but I wonder if part of your problem could be connected to your use of RTF:

This looks like a problem with Final Draft, not with Scrivener - if you open the same RTF file in any word processor it will look fine. So you will need to take this up with the Final Draft people. But why are you using RTF to go to Final Draft at all? Given that Scrivener supports Final Draft (FDX) format for export, why not just use that? You’ll get the best results all around.

All the best,
Keith

That should not be the case if you’ve followed the instructions provided in §20.2, “Using Page View to Estimate Page Counts”. There are some important settings that need to be adjusted in order to achieve better pagination accuracy. There may still be discrepancies (the additional “Continued…” text that programs like Final Draft will add where dialogue cuts between pages, for instance will add bulk not seen in Scrivener), but it definitely should not be as dramatic as adding space before every scene cut.

Beyond seconding Keith’s advice to use the Final Draft format when working with Final Draft, you should also make sure that the Separators compile option pane is not generating any extra spacing. Its default settings are for prose, which would have scenes of a novel separated by an empty line in accordance with modern printing practices. For screenplays you would only want a single return added between text files, not an empty line.

That probably has nothing to do with the \pard code in FD, but would be important if you are printing straight to PDF or taking this script to a standard word processor.

For compile, easiest thing to do is select “Script or Screenplay” as your Format As compile preset. It will have sensible defaults selected for all of the main file formats.