Screenplays in Scrivener: Jumping around and RTF exports

After loving Scrivener for Windows for my noveling, when an opportunity to write a screenplay came along I fired up Scrivener right away.

So far it’s been great, except…

  1. New line. I tab to add a character name. If I hit enter and go straight to dialogue, I’m good. If I add (V.O.) or (CONT.) and let the autocomplete finish it for me and hit enter, I jump to the top of the page. The cursor remains in the dialogue spot where I wanted to be and if I keep typing the page jumps back down, but it’s distracting.

  2. Exporting to PDF works wonderfully. When I export to RTF, I only get the first scene, even though all of them are checked in the Compile settings.

Currently using 1.01.

Going from memory: 1.01 isn’t the newest version, i think this was fixed in 1.02 or 1.03, you should upgrade to the newest version.

As shimra said, the jumping issue from hitting Return after an auto-completion should be fixed in 1.0.3, but let me know if you’re still getting that problem after updating–and if you are, providing specific steps to reproduce it would help a great deal, as I’m not able to replicate the issue in the 1.0.3 version.

I’m also not sure what you’re seeing with the RTF compile, as in my admittedly brief testing, RTF compile works to correctly incorporate all the selected contents, so there may just be some setting off in compile–e.g. “text” might not be selected as an included element for all the proper document types or levels in the Formatting pane. If you’re still seeing this, could you attach a screenshot of the Draft in the binder and of your compile settings (or save your compile settings and then attach that file here so I can just load them to test with the same settings–you may need to zip the file to upload it to the forum). Thanks!