Screenwriting on App (questions and issues)

Here’s a few things I’ve come across; let me know what you guys think, or if you’ve found workarounds:

  • How do I apply and format a Title Page on my screenplay (Project Title, Name, Contact Info, Date, etc)?

  • How do I format page numbers in the header so they appear in the top right hand corner? It seems, no matter what I do, that the page numbers appear in the middle of the footer.

  • How do I make sure that no page number appears on the first page of the screenplay, and that they only begin on the second page with the number “2” to conform to industry-standard formatting?

  • Also, (I could be wrong), but the page numbers appear to be in a different font from Courier. At least they appeared to be when I imported an existing .FDX screenplay. Thoughts?

  • I also noticed a strange page number error when importing an .FDX screenplay. It removed my page numbers, and moved them to the middle of the footer. Any ideas?

  • Is there a way to element the endless scrolling feature? I’d love to be able to write and know where I am, page-wise, without having to export to PDF.

  • Is there a way to write within different formats? For example, a TV pilot with act breaks?

  • Is there a way to import an .FDX screenplay and ensure that the title page comes too?

  • When I imported an .FDX screenplay, (and then exported it to PDF) it added a blank page at the end. This page does not exist within Scrivener while editing the document. Any idea why?

Thanks guys!

Hi,

One thing to remember is that, although you can write a fully-formatted screenplay in Scrivener, you will probably need to make some final tweaks in a word processor or Final Draft if you absolutely need to meet the demands of Hollywood agents or producers. These tweaks will mainly involve the title page and headers and footers. Bearing that in mind:

You can just create a document as the first time in your Draft folder and type out the title page. So, you would change the font to Courier or Courier Prime, hit return a few times, type out the title and author and centre it, then hit return a few more times and type your address (now left aligned). You might need to compile a couple of times to check the number of spaces you need to get this look right for your page size.

When you go to Compile, choose the “Script” Appearance you will see “Header” and “Footer” options in the "Page Options area. Remove the “<$p>” tag from the footer field and add it to the header field instead. In this format, the header is set to be right-aligned and the footer centre-aligned, so this will do what you want. (You can create your own Appearance templates that control header and footer alignment.)

Scrivener can skip adding headers and footers to the title page, but I’m afraid it cannot omit the first page number, which is what you need here. The best thing to do is export to Final Draft if you have it, or export to Word format and tweak this in a word processor after you’ve finished your script.

If you export using the “Script” Appearance, they will be in Courier. Again, that’s something that is set in the Appearance template.

If you were using an Appearance template that was set to show page numbers centred in the footer (such as the “Default” Appearance), this is how it will have appeared in Final Draft too.

I’m afraid not. Page view isn’t supported in the iOS version.

The iOS version only has screenplay format built into it. However, if you have the Windows or macOS version of Scrivener, they provide a range of different script formats, and you can create your own, too. If you edit a Windows or macOs project on iOS, iOS will use the same script format settings that were applied on the desktop.

I’m afraid this isn’t currently supported, although that could potentially be added to an update because the code I wrote for FDX import can grab the title page text.

[quote=“ianmk”]

  • When I imported an .FDX screenplay, (and then exported it to PDF) it added a blank page at the end. This page does not exist within Scrivener while editing the document. Any idea why?

[quote=“ianmk”]
Check to see if there is an extra empty line at the end of the text.

Hope that helps.

All the best,
Keith