Scrievenings Export to Text as .mmd not .txt, unless...

Scrivener 3.0.1 MacOS 10.13.2

  1. Select a contiguous group of text documents in the Binder
  2. File > Export > Files…
  3. In the Save As dialog, enter a folder name in “Save As” field
  4. In “Export text files as:” choose Plain Text
  5. In Options, notice that “Append .txt extension” is already selected
  6. Click Export
    Result: The separate files appear in a normal folder, but with .mmd extensions (and they are indeed not txt files)
    Workaround: Export the text docs from the binder individually, and txt files appear as expected, in a normal folder.

Not a huge problem since there is a viable workaround. But if this “bug” is the programmed behavior, the option to save as txt should not appear if a group of files have been designated to save.

Alternate version #1 of this…
Step 4: Actually tick “Append txt extension” from off to on (blue)
Notice this adds .txt to name of folder in SaveAs field (weird!)
Result: You actually DO get individual txt files, but in a folder without a standard OS directory icon

Alternate version #2
Step 4: The dialog opens with “Append txt extension” not ticked. Don’t tick it
Result: Normal folder icon. In it txt files of each doc as expected, but files do not have .txt extension.

I’m using alternate version #1, but have to edit off the .txt from the folder name if I’m being fussy about having a neat-looking directory.

Still very happy with the new version.

Thanks - I’ve fixed this for 3.0.2.

All the best,
Keith

Oh good. I use this feature almost daily to export my latest changes to LeanPub. I’ve built in an automator-based workaround, but having this go back to normal will be quite helpful.