script mode and none script mode in one project?

First off, Hello! I’ve recently started using scrivener and am loving it. Works just the way my brain wants to… fantastic!

So my question/situation is this. I have been working on a short film script. In order to get a different perspective on the material, I thinking of reworking the script into a short story. I would like to go back and forth between the two versions easily, so would like to keep them all within the same project file. Only problem is, you seem to be only able to be in script mode or not in script mode. Is there something I am missing or is it just one or the other (and should I even be worrying about this)?


Scrivener is very capable of handling a dual-mode project like this, in fact it would make a good tool for adaptations in either direction. How to organise the project is a matter left up to you, but if this were my project, I’d put the existing script into the top level of the Binder (or perhaps in Research, and rename it to something better suited), and start building the story in the Draft. Now the first time you create a new document in the Draft, since you’ve been working in script mode, the new document will probably be in scriptwriting mode to start with. This is not a problem, though. Just press Cmd-3 to switch to standard mode. You’ll know you’ve made it when the footer bar no longer has the scriptwriting hints and type menu in it.

From that point onward, every new document you make should be a standard mode document. Scrivener keeps track of the last document you specifically switched, and assumes you want to work the way you switched it to from that point onward. Additionally, each document keeps track of its own mode as well. So you can go from document A that is in scriptwriting mode, to Document B that is standard mode, and Scrivener will switch the interface for you each time. You shouldn’t have to worry about that aspect at all.

Using split screens to manage the original script on one side of the screen, and the evolving narrative story on the other, would be a great way to go about working.

Amber, thanks so much for this tip.
We’re working on a new screenplay idea.
Started up in the default mode, with all notes in Research folder
And a trial opening scene in Draft.
Just tried the Cmd-3 trick with a new item.
And now have the screenwriting mode there.

Excellent, sounds like you have the MBP operational with the separate keyboard, then?

Um, nope. Working on an older MBP, while its owner (spouse) makes do with iPad. :blush:
She drafts notes and such, passes them to me via e-mail; I plunk into Scrivener.
We’re backing up constantly on iDisk and will survive till end of this trip.

I mentioned in another thread that the damaged MBP will not recognize our wireless keyboard.
Tried going through the Keyboard preferences, changed batteries, but just doesn’t work.


Yes, as Ioa says, you can just use Text > Scriptwriting > Script Mode to switch between modes on a document-by-document basis. That is, each individual document within Scrivener remembers which mode it should use. New documents will use the mode of the document that was selected when you created the new document.

Actually, there might possibly be a bug leftover which caused non-script documents to get opened in script mode if the last document was a script document - although I’d thought this was fixed in 1.54. But if you see this, just switching back to regular mode should cause it to get remembered for the affected document. Let me know if you see this behaviour, though, because if documents aren’t remembering their mode, then that’s a bug.


Thanks Amber/Ioa and Keith. Don’t know what I was doing wrong before, but I’ve got it setup that way I was hoping I could now so thats all that matters. Thanks again.


A minor problem: although we are set in Script mode and formatting each element, on reopening the file later, all the elements are properly formatted but identified as General Text.

Will that be a problem when compiling and exporting to Final Draft? Should we have some preference set differently?

I read the Help and FAQ wiki and did not find this issue.

Yes, that would be a problem - the elements have to be recognised properly in order for the FDX export to work properly.

Have you changed the script settings at all? The various elements are recognised by their formatting, so if you change the formatting they will no longer be recognised - you will need to ensure the script settings match the text formatting. If you tell me a little more about how you have set things up and what sequence of events led to the elements not being recognised (it must be more than just reopening the file later - something must have been changed in between) then I’ll do my best to help you sort it out.

Try looking through the various files in the project - are newer ones okay and older ones not (which would indicate that maybe the formatting was changed in-between)? You can also send the file to me of course (zipped) and I’ll be happy to take a look.

All the best,

I’m following the advice Amber gave in this thread (just above), to use Cmd-3 to change from Script to Default; keeping those Binder items separate in the Draft and Research folders: Draft are Script; Research Default.

I notice that whenever I start a new item, it retains the last mode I used, until corrected by Cmd-3. But all of the items reverting to General Text are set to Script.

Other than that, the only Preference change I made was to check “Capitalize first letters of sentences,” which was off. I’m working on my partner’s machine, so the Prefs are not identical to mine at home.

Sent you the zipped file. Also, at times, I am copy/pasting from Research folder to Draft. Would the new material offset the preferences for the Draft (Script) side?

If you are copying from Research into the Draft folder, you should use Paste and Match Style, otherwise it will get pasted in as non-script formatting. I’ve just sent you a reply - your project looks fine as far as I can tell, but I didn’t check every line of every document.

If you look at that third scene, “class,” it’s all coming up as General Text, despite the formatting. I tried to correct it twice. The fourth and fifth scenes are fine.

Curious. Although the formatting seems to be the same, there is a subtle difference. The text in “class” has a default tab interval of half an inch, whereas the text in the other document does not. The default tab interval isn’t even something you can normally set - in fact it’s hidden in an “Options” pane of the Script Settings in the “Paragraph” formatting tab. So the question is, how did one document get this default tab interval set? Was it text you imported or pasted from elsewhere, or was it created in an earlier version of Scrivener (not that I think this setting has changed)? Have you used a different script format for it before, or changed the script settings at all?


Yup, that was it. Source for that file was text in an e-mail message. I copied and pasted it into a Default item, then later to a Script item, and the Default ruler prevailed.

So I copied a Ruler from a “good” Script item, pasted it into the “bad” one, and then reformatted each of the script elements. Saved, closed, reopened the project, and the new Ruler prevailed.

This usually doesn’t happen because we trade zipped Scrivener files, instead of working via e-mail.

Thanks, Keith.

If you are e-mailing from two Scrivener projects, you should definitely check that the scripts settings are the same in both. Did the source come from another Scriv project, or from elsewhere?

It started with email, pasted into Research, and then I pasted from the Research folder to Draft. Should the Ruler be identical in both Draft and Research, even if their formats differ? I create the Research items with the Cmd-3 trick Amber described at the outset of this thread.

All cmd-3 does is switch to script mode, and all that does is make the script controls available every time you view the document - it makes no actual changes to the text itself. So if you took the text from an e-mail and then applied the script formatting to it, it should have stuck. However, if it was in script format in the e-mail or you had formatted it manually rather than using Scrivener’s controls, then there would have been a difference.