Script Mode – Compile Formatting Change

Hello – I’m new to this forum and seeking some help. I’ve recently started using Scrivener to write a screenplay. When I compile and export to PDF, the formatting changes very slightly. I’ve attached two screenshots that exemplify this – the black one is Scrivener and the white PDF. On the last line, you can see that after the word ‘bank’ the PDF has started a new line with the next word, leaving me with a widow and more lines than I wanted. I am using the font Courier (rather than Courier Prime) as I know this can cause formatting problems. Can anyone help or offer any advice?
Thanks in advance.


Hi,

This is actually a feature of the scriptwriting export (don’t worry, you can turn it off, as I’ll explain below). It’s standard in film scripts not only to avoid widows and orphans but also to avoid breaking a sentence across pages. So, the start of a sentence in a paragraph will get moved to the next page. In Scrivener, this is a setting in the Compile format, which you’ll want to turn off.

Assuming you’re using the “Screenplay” Compile format, here’s how you do that:

  1. In Compile, Ctrl-click on the “Screenplay” format in the list of formats and select" Duplicate & Edit…". (If you’re not using the Screenplay format but a custom format, you can just choose “Edit…”). This will switch the window to show the Compile Format editor.

  2. Select “Text Layout” on the left.

  3. Deselect “Avoid splitting sentences across pages”. (Also check the other options are as you want them.)

  4. At the top of the window, give the new Compile format a name and choose where to save it (either as part of the project or to the machine), and then click “Save”.

  5. Now use this new Compile format to Compile and all should be good.

Hope that helps.

All the best,
Keith