Script Mode - format returns to General Text

Hi all,

I’m trying to use the Script Mode to have different paragraph formats. I have customized the formats to the way I would like them, but after each line of Dialog style formatting, Scrivener returns to General Text if I hit a chariage return after the first line.

How can I keep a whole section of text as “Dialog” style?


You can change the default action for the Enter key for individual elements in Scriptwriting mode. Go to Format > Scriptwriting > Script Settings…, select the Dialogue element (on the left), then click on the Tab/return tab (on the right) to change its action. The “On return:” field offers a dropdown menu of all the elements set up – select Dialogue from this dropdown list if you want to set the carriage return to produce another Dialogue paragraph.

When you go back to your document and click in a Dialogue paragraph, the keystroke actions displayed in the footer will reflect your new setting, showing “[Enter] Dialogue” (i.e. when you press [Enter], you will get a new Dialogue element). Now, when you press return at the end of a Dialogue paragraph, the next paragraph will automatically be set to be a Dialogue element as well. If you need to change it to something else, just use Format > Scriptwriting > Change Element To and select from the dropdown menu offered (or use the shortcut keystrokes, if you’d prefer – these are listed in the dropdown menu).

Of course, you can define similar behaviour for the tab key instead of return, which might be useful if you want to set up a separate pre-set for moving to another element type at the end of your Dialogue section.


First, thank you for the above help. That does work on new paragraphs that I type. However, I could not reformat prior paragraphs to the style of Dialog, even though I would highlight them and use the Change Element To from the formatting menu. No matter what I tried, the text reverted to General Text.

Only when I took our every carriage return was I able to format my whole paragraph to the Dialog style. So how do you re-format paragraphs? And while we are at it, is there a way to select all the text that was written and now in the Draft folder and change it in bulk to a particular style like Dialog??


Could you please clarify what you are doing when you can’t get the element to change? Are you using a particular template? Are you working with the documents in a Scrivenings view, or separately?

When I select an existing paragraph in a different element style (or just position the cursor inside such a paragraph) then use Format > Scriptwriting > Change element to… and choose Dialogue, the paragraph is definitely converted to Dialogue format. The same happens if I use the “elements” control in the bottom right-hand corner of the window. I certainly don’t have to edit the paragraphs to achieve this. To change all the paragraphs in a document, I just select them all (using Cmd-A) then do the same. I’ve tried several times in different documents and projects, and the element has changed each time.

The only scenario I have found where this doesn’t work is if my text selection spans multiple documents in a Scrivenings view – could this be what you are doing? Does it work if you handle each document separately?

As far as changing things in bulk goes, is this something that you need to achieve within your writing environment in Scrivener, or is it something you wish to control on output (i.e. at the compilation stage)?


Here are my answers to your questions:

  1. Are you using any template? Yes, I started with the Screenplay template and have modified that.

  2. Are you in Scrivenings view? Yes

  3. Can I change multiple “elements” to a style? Nope. Doesn’t work. Assuming an “element” is a distinct piece of text that is under the Draft folder, then if I select multiple “elements” and choose Change element to… Don’s Screenplay (my template) then it says ok, but in reality, nothing changes. You can only change the “Script Mode” if you select one element, individually, but not multiple elements.

  4. Even after I have individually changed some of these “elements” to Script Mode - Don’s Screenplay, and then select all the text within these “elements” it will only let me change the very first line of the first “element” to the paragraph style I want.

  5. I’m looking to change, in bulk, the way I see the text within Scrivener first. I haven’t even gotten to the output yet.


Ok, I just dug more into the manual and found this gem:
“Scriptwriting mode is a setting which is individual to each document.” Thus, the “documents” are what I referred to before as “elements” and they can ONLY be put into Script Mode one at a time. Not in bulk.

Next, you can change all the text within one “Document” to be of a certain Script Style, but you while you can select all the text within all the Documents by click on the Draft folder and clicking the “Composite” or “Scrivenings” view of all and then use a CMD A to select - it won’t let you change the Script style of all the text throughout all the documents this way either.

So, correct me if I a wrong, but apparently you have to manually go to each document to effect a change of the Script styles. Which most certainly can be a pain on a big file with many documents.


Ah, that would explain why we’re talking at cross-purposes. The paragraphs within a document are set as elements, not the documents themselves. This is so that you can lay out the script easily – for example, indicating who is going to do something is one element (character), and indicating what they are going to do is another (action). You wouldn’t split these two bits of information across separate documents because they don’t make sense on their own, but you do want to format them differently within a document. Scriptwriting elements are not designed to handle the format of entire documents.

If you are not actually writing a script, and if you are just trying to set up different documents (in your binder) to appear differently on screen, I think that you would find it much easier to achieve what you want in the normal mode rather than script mode. Script mode is designed to help with very specific formatting requirements which change (and need standardisation) within the body of each single document. The regular mode is more appropriate for documents where formats, ruler settings etc are maintained throughout the document, although different documents can obviously be set up differently.

To my mind, the easiest way to change the formatting of entire groups of documents (so that they all end up the same) is simply to make sure they are not in script mode, then open them in a Scrivenings view, use Cmd-A to select all the contents, then set up the font, ruler etc. If different documents need different settings, repeat the process with the next group of documents. (If you use meta-data to indicate which group a document belongs to, you will be able to use Collections with a meta-data search to separate out those documents whenever you need them.) This will get your existing documents into the format you want.

If you want new documents to have a single specific format you can change the default for your project via Scrivener > Preferences > Formatting.

If you want new documents to have one of several different formats, I would recommend that you set up document templates within your project. Section 8.4 (“Document Templates”) in the manual gives full details. Basically, in each document template, you set up the text format, ruler, meta-data, text etc that you want (if you are using Collections with a meta-data search to identify documents in a particular format, it would be a good idea to set that meta-data in the template document, so that the new document has the meta-data pre-populated and you don’t need to remember to do it manually). When you create a new document, use Project > New From Template to select the base template to be applied.

If you intend using this same setup for future Scrivener projects, it might be worth thinking about saving the whole set-up as a project template.